Sort by Album Artist Only?

Discussion in 'iOS 8' started by jayinla, Jun 30, 2015.

  1. jayinla macrumors regular

    Joined:
    Sep 17, 2010
    #1
    It seems that Album Artist is the default Artist sort in the new 8.4 upgrade. There use to be a toggle in the Music settings to turn that on or off. Am I missing something here? I would like to only sort by Artist.
     
  2. FrankieG889D macrumors member

    Joined:
    Jun 21, 2009
    #2
    In the music app, under the "My Music" tab, you can sort by Artists, Albums, Songs, Genres, Composers, and Compilations If you click the red lettering pretty much in the middle and switch to whatever you want.
     
  3. jayinla thread starter macrumors regular

    Joined:
    Sep 17, 2010
    #3
    Yes...but if you select Artists, it's using the Album Artists field not the Artist field. There use to be a setting to change this but cannot find it anymore.
     
  4. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #4
    Nope, it's not an option anymore. Not even in the Settings area.
     
  5. melissapete24 macrumors member

    Joined:
    Feb 12, 2013
    Location:
    Pennsylvania
    #5
    Does anyone know if there is a workaround for this? I like to shuffle an entire artist, but about 25% of my music library (of close to 3,000 songs) are albums by "various artists". For example, I have two albums by Johnny Cash, but I also have 8 albums of 30 songs each of classic country songs from the 50s through the 70s, and there are several Johnny Cash songs scattered throughout them. However, whenever I select Johnny Cash under the artists, it only has the two actual albums, not the random songs from the Classic Country album series. I want to shuffle ALL my Johnny Cash songs, not just the songs from two albums. Is there a way to work around this? I'm desperate enough to try anything at this point. It's driving me NUTS. I had EVERYTHING set up perfect on iOS 8.3, and now everything is basically ruined.
     
  6. jayinla thread starter macrumors regular

    Joined:
    Sep 17, 2010
    #6
    I hear you! This sucks. The only workaround I could find was to actually make your compilation album was not set as a compilation in iTunes and make sure you fill in the album artist field the same as the artists field for each song. A total PITA.
     
  7. IronWaffle macrumors 6502

    IronWaffle

    #7
    I've written feedback about this and recommend others do too.

    The workaround in the above post should do the trick. Me, I'm not contorting my actual library to fit Apple's questionable choices here. I'm also holding off on 12.2 so that Apple doesn't contort my library to fit its questionable choices. Instead, I rely on third-party apps which are minimally affected by IOS 8.4's arguable oversights and many shortcomings.

    Ecoute and especially Cesium (99¢ each, I believe) are very iOS 6-like in their intuitive navigation. They also circumvent this specific problem completely from my spot checking.

    Marvis is my current go to and it's free. It handles the library in a way that's a hybrid between iOS 6 and 7. It is very customizable. Default settings are very good though you'd probably want to tweak it. Edit: Similar spot-checks suggest this app doesn't correct this compilations quirk. I'll contact the developer to see if that's the next version
     
  8. Aditya Rajveer, Jul 9, 2015
    Last edited: Jul 9, 2015

    Aditya Rajveer macrumors regular

    Aditya Rajveer

    Joined:
    Jun 2, 2015
    Location:
    Gujarat, India
    #8
    I'm replying here, even before you contact me.


    I hope I've understood the query correctly. Marvis does show all the albums under the Artist even if the Album info is Unknown, that depends on what results Apple's API send in return to the query. Make sure you are in Artist View not Album Artist. You can have both views at the same time in Upper Tab. No need to go to settings and toggle Group by Album Artist.

    Try and see if it works out, if it still doesn't show all you items you can go to Grouping Type setting in Marvis and select No Grouping. It'll list all the songs in your Artist Alphabetically.

    You can even Tap and hold the Artist and press Play/Shuffle to Play all the songs in that Artist.

    Let me know if that helps.

    Update: Okay I rechecked, in the Current Version, the Compilations won't be visible in Artists View. I have already resolved it, It'll show up in the Next version.
     

Share This Page