SOS: My HP Printer

Discussion in 'Mac Basics and Help' started by zblaxberg, Feb 18, 2008.

  1. zblaxberg Guest

    zblaxberg

    Joined:
    Jan 22, 2007
    #1
    Ok so I've had this printer work before. I recently went and formatted my mbp and went to install my hp psc 3100 printer and the whole installation goes well except it gets to the setup wizard at which point I'm to select my printer yet nothing shows up. The printer is plugged in, powered on and all. What do I do??
    I found a driver on the hp website figuring maybe the cd doesn't have a universal version that is compatible with leopard so we'll see what happens. Does that sound about right?
     
  2. motulist macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #2
    Are you sure the USB cable is in securely at both ends? If so, try a restart and run the installer again.
     
  3. zblaxberg thread starter Guest

    zblaxberg

    Joined:
    Jan 22, 2007
    #3
    This screen is all I get, I know its plugged in, I checked and it hasn't moved since I formatted the laptop.
     

    Attached Files:

    • hp.jpg
      hp.jpg
      File size:
      20.7 KB
      Views:
      34
  4. zblaxberg thread starter Guest

    zblaxberg

    Joined:
    Jan 22, 2007
  5. pilotError macrumors 68020

    pilotError

    Joined:
    Apr 12, 2006
    Location:
    Long Island
    #5
    I recently set up a friends Mac who's HP printer stopped working after going to Leopard.

    To fix the problem, there's instructions on HP's web site to completely remove the software and then do a fresh re-install using the download from their site.

    I had a hell of a time getting it to work, but after killing all the HP software, I re-installed the latest from their site and it started working again. It took a while to get the instructions though. They said to just remove the drivers in their instructions, but I eventually went into the HP directory under applications and ran their uninstaller. Once I did that, the fresh install did the trick.
     
  6. zblaxberg thread starter Guest

    zblaxberg

    Joined:
    Jan 22, 2007
    #6
    That worked, thanks!
     

Share This Page