Sound cracking in iTunes 7

Mac Rules

macrumors 6502
Original poster
Jul 15, 2006
485
322
Switzerland
Hi guys n girls,

well as the title suggests, every so often iTunes, after working perefctly fine, will suddenly start crackling, every song. The only way to stop itis to close iTunes and reopen it. I've reinstalled iTunes + Quicktime both together and indiviually...

Any ideas?

Cheers
 

ncfcstar

macrumors member
Aug 25, 2006
61
0
Near Ipswich, UK
This happened to me while I was listening to a podcast. I realised it was every time i loaded a new page on Firefox, really strange, doesn't happen when I'm listening to music though :confused:
 

mleary

macrumors regular
Sep 13, 2006
145
0
I'm having the same problem with Itunes 7 on windows. Music cracks/skips really badly, can't even listen to it. It does not happen all of the time, but most of the time.
 

Osarkon

macrumors 68020
Aug 30, 2006
2,161
4
Wales
I think that this issue in Windows at least is due to the sound drivers, i've had the same problem, but with any media player. it tends to happen more when i for example, switch focus on windows, minimize, maximize, open a menu. whatever. but it also does it when it's idle. :confused: haven't come across the problem on the mac side though.
 

mmmcheese

macrumors 6502a
Feb 17, 2006
948
0
I'm having distorted sound in iTunes7/Quicktime on OSX Tiger...this was never an issue with iTunes 6....hopefully someone figures out what is going on.
 

Mac Rules

macrumors 6502
Original poster
Jul 15, 2006
485
322
Switzerland
Well my temporary solution to this is that I turned off all the alerts from Live Messenger, this means that I can listen to music for longer, but if I open a new window it'll do it....

They really need to reduce the amount of RAM iTunes is using, when using Coverflow, my RAM usuage goes all the way to 155Mb!!!!

I'm not very impressed at the moment!

Cheers
 

Jimmery

macrumors member
Jul 25, 2005
86
0
Canada
something that helped me:

In iTunes, try:
Edit --> Preferences --> Playback (tab) --> Sound Enhancer (make sure it's checked)
 

tacoboy42

macrumors newbie
Jun 6, 2006
7
0
i had to go back to 6.0.5 you can find instructions how to do it, only thing that worked for me.