Sound in Simulator stopped working?

Discussion in 'iOS Programming' started by Soulstorm, May 25, 2009.

  1. Soulstorm macrumors 68000

    Soulstorm

    Joined:
    Feb 1, 2005
    #1
    I have a project which I use to test sound using OpenAL. I made this using 2.2.1 SDK, and now I have upgraded to 3.0 beta. At first, the sound was playing correctly, no problems at all, even when I made my first build with 3.0. Sound was working with 2.2.1 and 3.0.

    But now, it stopped working on the simulator, just like that!

    Now, when my SFSoundManager class is trying to initialize, I get this:
    Code:
    [Session started at 2009-05-25 17:10:10 +0300.]
    2009-05-25 17:10:24.509 OpenALTest1[424:20b] SFSoundManager initializing
    2009-05-25 17:10:24.510 OpenALTest1[424:20b] -[SFSoundManager init]:-[SFSoundManager init]
    2009-05-25 17:10:24.511 OpenALTest1[424:20b] -[SFSoundManager initOpenAL]:-[SFSoundManager initOpenAL]
    [17:10:28.896 <AURemoteIOServer>] AQMEIOBase::DoStartIO: timeout
    [17:10:29.173 <AURemoteIOServer>] AQMEDevice::StartIO: AudioOutputUnitStart returned -66681
    [17:10:29.173 <0xa0084720>] AUIOClient_StartIO failed (-66681)
    2009-05-25 17:10:29.811 OpenALTest1[424:20b] hello world!
    ...and then the application starts without any sound at all!

    When I run the program on my device everything is normal. It's just the simulator that has the problem. Tried restarting but no improvement was made. Any ideas on what might cause this?
     
  2. MightyMN macrumors newbie

    Joined:
    May 25, 2009
    #2
    I'm not sure if this is much help, but I've been using the SoundEngine provided in one of the Apple sample projects (Crash Lander I believe) and it's very sketchy in the simulator. Sometimes it works, sometimes it doesn't. Recently it's been working with sound effects (wavs), but when I try to load a background track (mp3) the application just hangs indefinitely.

    Likewise, everything seems to work fine on the device though.
     
  3. Soulstorm thread starter macrumors 68000

    Soulstorm

    Joined:
    Feb 1, 2005
    #3
    I'm not using SoundEngine... I have a custom sound engine of my own design which seemed to work fine... Even when I start a new project doesn't seem to work either.
     

Share This Page