Sound not coming through tv when connected to HDMI

Discussion in 'MacBook Pro' started by tonyfnb, Oct 8, 2017.

  1. tonyfnb macrumors newbie

    Joined:
    Oct 8, 2017
    Location:
    Beaufort, SC
    #1
    Hey I'm Tony and I'm a newb here...So i have had this macbook pro for over a year now and NEVER had a problem...i plug it in via HDMI and the sound comes through the tv...i use XFINITY and NFL Sunday Ticket a lot...never had a problem..about 3 weeks ago the sound stopped coming through the tv..and was only coming through the computer...i noticed if i went to youtube it worked fine...and all apple stuff like iTunes and that kind of stuff works coming through the tv..i chatted with apple and they had me do the NVR or whatever reset and that worked but then stopped working the next day...then they had me do another reset where i hold shift control option and power for 15 seconds and that worked but then stopped...i have gone in to pref and manage website data and removed all that..again that worked for a minute then when i plugged in the next day it didn't work...now i have tried all those again and nothing is working...just youtube and just iTunes again...im using safari...my OS is 10.12.6

    Thank you for any help
     
  2. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #2
    Is the HDTV selected as the output device in preferences--> sound?
     
  3. tonyfnb thread starter macrumors newbie

    Joined:
    Oct 8, 2017
    Location:
    Beaufort, SC
    #3
    Yeah it changes over to whatever tv its plugged in to but continues to come out of the MacBook...UNLESS its youtube or itunes type things....
     
  4. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
  5. tonyfnb thread starter macrumors newbie

    Joined:
    Oct 8, 2017
    Location:
    Beaufort, SC
    #5
    Yeah different HDMI cables...different tv's...also if it works perfectly fine on youtube and iTunes things like music and movies...and doesn't work on these other websites...then it has to be something settings wise you'd think right?
     
  6. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #6
    Yes, it could be something in the app settings, not the system preferences.

    Everything worked fine on Sierra? Maybe do a Time Machine backup and try high Sierra?
     
  7. tonyfnb thread starter macrumors newbie

    Joined:
    Oct 8, 2017
    Location:
    Beaufort, SC
    #7
    yeah i may have to do that
     

Share This Page

6 October 8, 2017