Sound problems with vlc in yosimite

Discussion in 'Mac Apps and Mac App Store' started by Popis1991, Oct 23, 2014.

  1. Popis1991 macrumors member

    Joined:
    Oct 10, 2011
    Location:
    Sweden
    #1
    Hey guys!

    I just updated to Yosimite and now when i plug my macbook pro into my tv i cant get the sound to work properly.
    All the backround noise works fine, all the intros work but no voices will play, as soon as people start talking it's quiet.

    For example i played an epsiode of the Big Bang Thoery and the intro sounds perfect, the laughter of the audience works great but when the cast is talking, its quiet.

    The weird thing is that when the computer is not plugged into my tv, everything works perfectly! And i have the same propblem with my girlfriends macbook air.

    All other apps work perfectly too (spotify, youtube and so on) but for some reason vlc wont play any voices....

    Does anybody have a solution to this problem? It has always worked before....
     
  2. Victor Star macrumors member

    Joined:
    Dec 3, 2008
    #2
    It sounds like vlc might have surround sound turned on for some reason. Check the sound preferences in vlc and see what they are set to. If it looks like it's correct try toggling the settings on and off to see if that clears it up.
     
  3. Popis1991 thread starter macrumors member

    Joined:
    Oct 10, 2011
    Location:
    Sweden
    #3
    Hmm iv been looking around everywhere and i cant really find that setting? Any tips?
     
  4. Victor Star macrumors member

    Joined:
    Dec 3, 2008
    #4
    the setting I was thinking might be a problem is under "VLC" on the menu bar. Next go to "Preferences" and then select the "Audio" tab at the top. There is a "Force detection of Dolby Surround" setting. I would turn it to "Off".

    It could be a setting on your TV also.
     

Share This Page