Sound stopped working?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Kurt Hustle, Jul 30, 2007.

  1. Kurt Hustle macrumors newbie

    Joined:
    Jul 16, 2007
    #1
    Hey guys...was using my iPhone to listen to some songs on the way home from gym. When I got home and took the headset out I noticed that the sounds of everything no longer work...the clicking of the keys when typing..incoming text messages...sound when I hit home key...sleep on and off. The speakers work fine when trying to play a song...anyone ever experience this? I shut it on and off, no luck.
     
  2. mikahopity macrumors member

    Joined:
    Jun 28, 2007
    #2
    I ran into the same thing, except my microphone didn't work either (i.e. making a call, they couldn't hear me)

    I sat on the phone with ATT for 3 hours, went down to a store got my SIM card switched.

    Long story short, had to trade the phone for a new one. Sounds like you're in the same situation.
     
  3. nelly001 macrumors newbie

    Joined:
    Jul 8, 2007
    #3
    Sound and mic stopped working

    I had the same problem while travelling
    Had been using headphones while driving on the phone. After removing headset no sound through speaker or mic.

    I managed to clear this up by pressing the home button and on off button at top together holding for 15/20 seconds which does a reset. I had to do this twice and then the mic and speaker came on again.

    3 days after doing this it still is working. I guess it's another software conflict.
     
  4. ThanatosId macrumors regular

    ThanatosId

    Joined:
    Jun 29, 2007
    #4
    Have checked to make sure that the button above the volume rocker isn't turned on. When that is on, all sound is silenced and only the music will sound. Let me know if that's the problem.
     
  5. dtivomem macrumors newbie

    Joined:
    Jun 26, 2007
    #5
    I had the same issue. I was listening to a podcast last night with the iphone earbuds. Later i did the software update, which required a full restore because i had modded to add ringtones. This morning i went to place a call and couldn't hear anything out of the ear speaker on the face of the phone. The phone said it was on a call but i hadn't heard dialing or anything else. I put the call on speaker and found that the other party was there but hadn't heard me and I of course hadn't heard them. This actually happened on two different calls. I thought i was going to need service for sure.

    I did try a reset of the iphone but this didn't help.

    I found this on the apple support discussion site.
    http://discussions.apple.com/thread.jspa?messageID=4985099&#4985099

    Basically that thread is other folks who had the same issue and they resolved it by plugging and unplugging the headphones. I tried this with standard (no mike) ipod earbuds and had to do it several times but it did eventually work. And now everything is working fine.

    I'm guessing this must be a hardware issue and not software because I hadn't used the earbuds at all after the forced reload during the update. A friend also said that she had heard this happening with the tmobile sidekick as well.

    If it happens again, i'll definetly be talking to my local genius. ;-)
     

Share This Page