Sound won't play, icons grayed out.

Discussion in 'MacBook Pro' started by Señor, Jun 26, 2014.

  1. Señor macrumors 6502

    Señor

    Joined:
    Jun 20, 2013
    Location:
    United States
    #1
    [​IMG]

    [​IMG]

    Tried rebooting my Mac and it won't help.

    Running a Mid 2012 15" MBP (Retina).
     
  2. Señor thread starter macrumors 6502

    Señor

    Joined:
    Jun 20, 2013
    Location:
    United States
    #3
  3. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #4
    Do you see the red light in the audio port ?

    Apply this (from the previous link) :

    "Look in the audio output port.
    If you see a red light, then the internal switch is stuck. Insert the phone jack a few times and see if that will trip the switch. If no success, try a cocktail stirrer or the like and jiggle it inside. If still no success, bring it to an Apple store.

    If there is no red light, try a PRAM reset:

    http://support.apple.com/kb/HT1379 "
     
  4. Señor thread starter macrumors 6502

    Señor

    Joined:
    Jun 20, 2013
    Location:
    United States
    #5
    There was a red light before, but now it's gone.

    A PRAM reset didn't fix it.
     
  5. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #6
    You might :

    - repair the permissions in Disk Utility

    - shut down the computer

    - reset the SMC

    Il the problem is still here (with no red light in the audio port), try the Terminal as suggested in the link.
     
  6. Señor, Jun 26, 2014
    Last edited: Jun 26, 2014

    Señor thread starter macrumors 6502

    Señor

    Joined:
    Jun 20, 2013
    Location:
    United States
    #7
    Didn't try repairing permissions yet. I'll try this and report back.

    Nope, I'll be trying Terminal next.

    Edit: It's telling me to enter a password in Terminal but when I try to type it in, it doesn't type anything.
     
  7. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #8
    That is normal : type your admin password, nothing will be displayed, then hit the Enter key.
     
  8. Señor thread starter macrumors 6502

    Señor

    Joined:
    Jun 20, 2013
    Location:
    United States
    #9
    Tried the Terminal command, it went through, I restarted my computer, and nothing.

    Is it safe to say my audio has malfunctioned at this point? I've tried resetting SMC, PRAM, and used Terminal.
     
  9. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #10
    Does "Sound" in System Preferences still reads "Digital Out --- Optical digital-out port" ?

    Can you select "Soundflower" there ?

    Couldn't Soundflower be the problem ?

    Also try using AudioMidi Setup... (Applications / Utilities).
     
  10. Señor, Jun 26, 2014
    Last edited: Jun 26, 2014

    Señor thread starter macrumors 6502

    Señor

    Joined:
    Jun 20, 2013
    Location:
    United States
    #11
    I doubt Soundflower could be the problem, because I've have that there forever and it never did anything.

    Edit: Red light went on for a few seconds again. Decided to look in it and this is the best I could take a photo of whatever it is.

    [​IMG]

    Is that white-ish grey thing in there a part of the Mac, or is that dust?
     
  11. Señor thread starter macrumors 6502

    Señor

    Joined:
    Jun 20, 2013
    Location:
    United States
    #12
    Gives me this.

    [​IMG]
     
  12. Señor thread starter macrumors 6502

    Señor

    Joined:
    Jun 20, 2013
    Location:
    United States
    #13
    There was dust inside, got it out, and now this.

    [​IMG]
     
  13. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #14
    I would say this points towards a mechanical problem in the audio port (?)

    Quote :

    "the internal switch is stuck. Insert the phone jack a few times and see if that will trip the switch. If no success, try a cocktail stirrer or the like and jiggle it inside"
     

Share This Page