soundflower (2ch)

gw0gvq

macrumors 6502a
Original poster
Jan 30, 2012
969
45
Barry, South Wales, UK
For some reason, I noticed the soundflower (2ch) driver in my sound preferences today. How do I delete it please only I've tried uninstalling it but can't. Dos anyone have any suggestions for me how to uninstall it please
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,256
9,976
California
For some reason, I noticed the soundflower (2ch) driver in my sound preferences today. How do I delete it please only I've tried uninstalling it but can't. Dos anyone have any suggestions for me how to uninstall it please
I believe there is a kext file for soundflower in this folder you need to remove then reboot.

Code:
/System/Library/Extensions
 
  • Like
Reactions: 960design

gw0gvq

macrumors 6502a
Original poster
Jan 30, 2012
969
45
Barry, South Wales, UK
I believe there is a kext file for soundflower in this folder you need to remove then reboot.

Code:
/System/Library/Extensions
It is but I tried to delete it last night and got the error message , ' “SoundflowerSigned.kext” can’t be modified or deleted because it’s required by OS X.'
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,256
9,976
California
It is but I tried to delete it last night and got the error message , ' “SoundflowerSigned.kext” can’t be modified or deleted because it’s required by OS X.'
Looks like they are using Yosemite and up kext signing to lock the file. Try this. command-r boot to recovery then in the Utilities menu launch Terminal and run the command below.

Code:
sudo nvram boot-args=kext-dev-mode=1
That will turn off kext signing protection. Now reboot to regular mode then delete the kext file.

Then command-r boot back to recovery and in Terminal run this command to turn kext signing back on.

Code:
sudo nvram -d boot-args
It would be a good idea to make a backup before you do this.
 

gw0gvq

macrumors 6502a
Original poster
Jan 30, 2012
969
45
Barry, South Wales, UK
Looks like they are using Yosemite and up kext signing to lock the file. Try this. command-r boot to recovery then in the Utilities menu launch Terminal and run the command below.

Code:
sudo nvram boot-args=kext-dev-mode=1
That will turn off kext signing protection. Now reboot to regular mode then delete the kext file.

Then command-r boot back to recovery and in Terminal run this command to turn kext signing back on.

Code:
sudo nvram -d boot-args
It would be a good idea to make a backup before you do this.
[doublepost=1471194096][/doublepost]It didn't work . Thanks for trying . I put the command in terminal in utilities but it said, there was no such command as 'bash' which was the command that came up instead of my name. I tried entering it a second time and same thing . It was funny because I went into restore and instead of the El Capitan system I got it seemed to go to the original OSX which was Mavericks. Thanks again
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,256
9,976
California
[doublepost=1471194096][/doublepost]It didn't work . Thanks for trying . I put the command in terminal in utilities but it said, there was no such command as 'bash' which was the command that came up instead of my name. I tried entering it a second time and same thing . It was funny because I went into restore and instead of the El Capitan system I got it seemed to go to the original OSX which was Mavericks. Thanks again
Ackkk! My bad. On El Capitan the command is different.

Command-r boot to recovery then run this command in Terminal.

Code:
csrutil disable
Then reboot and delete the kext file.

Then boot back to recovery and run this to turn kext signing back on.

Code:
csrutil enable
 

gw0gvq

macrumors 6502a
Original poster
Jan 30, 2012
969
45
Barry, South Wales, UK
Ackkk! My bad. On El Capitan the command is different.

Command-r boot to recovery then run this command in Terminal.

Code:
csrutil disable
Then reboot and delete the kext file.

Then boot back to recovery and run this to turn kext signing back on.

Code:
csrutil enable
Still the same (never mind) thanks for trying . It doesn't seem to like those commands in terminal.th
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.