Soundtracks Listed in My iTunes Library

Discussion in 'Mac Apps and Mac App Store' started by HannahSpring, Jul 16, 2007.

  1. HannahSpring macrumors newbie

    Joined:
    Jul 16, 2007
    #1
    Hey, I have a little problem I need to solve.

    The thing is that I have a few soundtracks but I can't seem to put them in the Library the way I want them to.

    OK, I'll make it as simple as possible with pictures so you can see exactly what I mean.

    I have a soundtrack and I'll just put it in the Library. Now there's an artwork for every single artist of the album.
    [​IMG]

    I can put this album together by selecting all the songs and set them as a part of compilation. I changed the option in the circle to YES.
    [​IMG]

    Now the album "sticks together" when it's sorted under ALBUMS.
    [​IMG]

    But when I sort my Library under ARTIST it splits and of course it appears under many new artworks.
    [​IMG]

    The question is: How can I put a soundtrack album together when I want to appear it under ARTIST listing and not make it split the way it did in the previous picture?

    Thanks for your help!
     
  2. Cinematographer macrumors 6502a

    Cinematographer

    Joined:
    Sep 12, 2005
    Location:
    far away
    #2
    Group Compilations

    From http://docs.info.apple.com/article.html?artnum=304297
    "To see all songs on a compilation CD grouped together in your library, make sure you select the “Group compilations when browsing” option in iTunes Preferences (click the General button). If this checkbox is deselected, all songs from compilation CDs appear individually by artist in the Artist list (in the browser)."
     
  3. HannahSpring thread starter macrumors newbie

    Joined:
    Jul 16, 2007
    #3
    Uhm, right, I see. But, unfortunately... it doesn't seem to work. Well, let's see:

    Ticked, ticked but still doesn't seem to work properly.
    [​IMG]

    [​IMG]

    [​IMG]

    I'd really like to know what I'm doing wrong. :|
     
  4. Cinematographer macrumors 6502a

    Cinematographer

    Joined:
    Sep 12, 2005
    Location:
    far away
    #4
    Ah, I see now.

    But you're not doing anything wrong. The above solution only changes the browser view. It is supposed to work the way it does in the list itself.

    Maybe you could work with one "Album artist" for the soundtrack and sort by that.
     
  5. HannahSpring thread starter macrumors newbie

    Joined:
    Jul 16, 2007
    #5
    Yeah, I guess that's the only solution. But I really hoped that there would be something that would make it. So the only way how to fix it is use one name for all artists... What a pity, I'm such a perfectionist!

    Thanks for your help!
     
  6. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #6
    Have you tried sorting using "Album by Artist"?
     
  7. HannahSpring thread starter macrumors newbie

    Joined:
    Jul 16, 2007
    #7
    OMG, thank you Nermal! This is just what I needed but I've never thought of this option!

    But there's one more question. Now when I use this "Album Artist" sorting, the problem is that the numbers of the tracks are not in order. Is there any way how to fix this?

    [​IMG]

    This the last thing on my mind I guess. :)
     
  8. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #8
    Hmm, they're arranged correctly for me, do you have the "Album Artist" tag (under Get Info) set the same for all the tracks?
     
  9. HannahSpring thread starter macrumors newbie

    Joined:
    Jul 16, 2007
    #9
    Yes, I do. I've also tried it with Shrek OST to see if something will change but no such luck. The numbers are still not in the right order. It seems that the tracks are sorted by original artists (Baha Man-->Dana Glover-->Eddie Muphy etc.).

    [​IMG]

    Maybe you have some other setting turned on?
     
  10. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #10
    Sorry, nope, I've just even changed a few things at my end and I can't replicate your problem. Sorry :(
     
  11. HannahSpring thread starter macrumors newbie

    Joined:
    Jul 16, 2007
  12. jca488 macrumors newbie

    Joined:
    Jan 13, 2008
    Location:
    east coast
    #12
    final solution

    I have run into this problem many times and its always a different problem
    so make sure all these steps are followed:
    Under preferences>general tab
    the "group compilations when browsing" is checked

    when you select all songs on your album and "get info" two boxes are checked
    the "album artist" - leave it blank - or main artist
    the "compilation" - yes

    for the album artist you can always put in the big artist name but if it is a soundtrack of a movie leave it blank. the album will show up as various artists when looking at it under coverflow but the artist column will keep the artists you like
     

Share This Page