spacebar for handtool / option for drag copy command no longer working in Illustrator

Discussion in 'Design and Graphics' started by craigverse, Oct 6, 2008.

  1. craigverse macrumors 6502


    Dec 8, 2006
    Reno, NV
    I do a lot of design work in Illustrator cs3.

    Normally when working with a document I use the spacebar to quickly bring up the handtool to drag around my document. This no longer works.

    Shift no longer works for keeping art proportional when scaling.

    Option no longer works when selecting then dragging artwork to make it copy.

    Pressing h on the keyboard still activates the handtool though, same for pressing something like a and bringing up the direct selection tool.

    Any suggestions on how to being back the other functionality on the keyboard? Perhaps a plist file I need to delete!

    Halp! I'd greatly appreciate it! :confused:
  2. jerryrock macrumors 6502


    Sep 11, 2007
    Amsterdam, NY
    Hold down Command+Option+Shift while starting Illustrator to reset preferences. This should be the first troubleshooting step.
  3. craigverse thread starter macrumors 6502


    Dec 8, 2006
    Reno, NV
    I'd actually forgot that trick. Thanks. That didn't work though. Then I went into system preferences -> keyboard shortcuts -> restore defaults thinking that might affect something.

    That however didn't work either. Then I restarted. It's still not working.

    One thing I noted is that when I press option when I have something selected I get the double arrow as if it's going to make a copy when I drag but then it doesn't.

    I do not get a hand tool when pressing the spacebar though. :[

    Any other suggestions out there?
  4. ox4dboy macrumors newbie

    Apr 15, 2004
    I just started experiencing this problem myself.

    There is a good discussion here:
    CS3 Bugs? Hand Tool & Proportional Scale Not Working

    None of those suggested fixes have worked for me, but they might for you? More or less, here is a summary of that link:

    1. reset AI's preferences by holding down SHIFT + OPTION + ⌘ (command/Apple) (Windows Shft+alt+ctrl) while starting Illustrator
    2. deleting Illustrator's preference file from your Mac "user"/Library/Preferences/com.adobe.illustrator.plist
    3. disabling Spotlight's shortcuts that use space bar in Spotlight's preference pane
    4. "somebody in another topic suggested to kill some processes in the Activity Monitor to see what was causing the trouble. I then found out that my helper was the trouble"
    5. go to window>workspace>default to resets the panels and the key commands
    6. update MS Office to the most recent patch
    7. "turn off the replication in Entourage and do it manually"
    8. Restart the Mac and DO NOT launch Entourage. Work like that for a while and see if the keys respond correctly.
    9. update Quicken if you have that installed
    10. quit VPN or other log on item that requires the use of a password

    I've tried all but 4,7,8, and 10 with no success. I am about to test those in a minute and will report back ASAP.

    Everything worked fine for me up until today; here's what's unique to today:
    • I did a "Save as..." from Illustrator CS4 to CS3
    • I enable File Sharing in my Network preferences today (for the first time) and copied the file to another computer via my Network
    • I opened the file in CS3 on the other networked computer when I noticed Space bar did not trigger the Hand tool. FYI _ i am not working directly from the Network.
    • I swapped keyboard and monitors via hot swap - unplugged from Mac #1 and plugged into Mac #2

    Other applications that are concurrently running:
    • Parallels
    • Outlook (via Parallels)
    • Firefox (Mac)
    • Font Explorer X Pro

    Before today I used the same applications + Illustrator with out problems. Anyone else have a suggestion or a fix?
  5. DennyMcEntire macrumors newbie

    May 20, 2009
    Quit Firefox

    I was having the same issue. VERY frustrating. After reading this thread I noticed that I, too had Firefox opened (same as ox4dboy). So I quit firefox and my keyboard shortcuts were back! Seems like a pretty obscure bug.
  6. DennyMcEntire macrumors newbie

    May 20, 2009
    Another program

    Another program that seemed to break it today was Textmate. Just thought I'd capture that here in case it's useful to anyone else.
  7. cyarema macrumors newbie

    Sep 7, 2007
    Microsoft Word

    I've had the same problem was that the I opened word before opening illustrator and throwing all my illustrator preferences off. But as long as i remember to open illustrator first, I don't have that problem. So aggravating. Took me days to figure it out.
  8. cardboardcowboy macrumors newbie

    Feb 28, 2008
    I have just experienced this issue for the first time and that's the reason I found this thread.

    I can add that the problem for me was with the recently released Hulu Desktop application. My spacebar wasn't bringing up the hand tool so I closed the Hulu app and all is well again. It could be because the app supports the use of an apple remote (a feature I love, by the way). I've never had any issues with any other programs though. Just thought I'd give a heads-up.
  9. Alona macrumors newbie

    Aug 14, 2009
    tried everything described above...

    Hi. I am still having the same issues, with Illustrator CS4.

    - hand tool doesn't come up with spacebar pressed
    - shift doesn't help to scale proportionally
    - holding option and dragging (even thou it gives a double arrow) doesn't copy
    - space+apple key for Zoom+, and space+apple key+option for Zoom- don't work either (used them for years - soooo frustrating!!)

    Tried trashing AI prefs, quitting Safari, word, VPN, Mail... disabled Spotlight space prefs... Nothing works!!

    Please help!
  10. Alona macrumors newbie

    Aug 14, 2009
    me again...

    whatever it was - it finally just got fixed!!!
    right after i posted my message. i kept trying all the solutions described above, and something did the trick... not sure what exactly, as by that point i was already pretty desperate and didn't keep track of what and in what order i was doing....

    thank you for sharing your experience!

  11. linzibop macrumors newbie

    Nov 17, 2009
    Well would you know it, Word was the culprit for me! Had to trash preferences and restart, but thank god that panic is over! Thanks god for this forum!
  12. Steffy15 macrumors newbie

    Nov 11, 2009
    Web Browers Interfering

    If you're having problems with Firefox etc affecting Illustrator try using this browser instead

    I have just downloaded it to try it and see if this works better than Firefox with Illustrator open.
  13. maximusimo macrumors newbie

    Nov 25, 2007

    was experiencing the same problem. Turns out after closing my open apps one by one it was only when I closed my Internet Browser Camino that Illustrator returned to normal. I restarted it after closing each app by the way.

    Hope this helps someone else
  14. greezychicken macrumors member

    Apr 23, 2005
    I've had this same problem and it frustrated me to no end. It ends up the culprit was Firefox 3.6 Beta 5. Everytime I had Illustrator and Firefox 3.6 open the issue would happen. It's weird because Firefox 3.5 (the current stable mass version) was perfectly fine.

    Oh well.
  15. soccerkingpilot macrumors newbie

    Mar 8, 2010
    Hulu Solution

    I had the same problem which was easily fixed by restarting Hulu. The way I understand it you have to open illustrator before Hulu to avoid problems.
  16. design-is macrumors 65816


    Oct 17, 2007
    London / U.K.
    Just experienced this issue for the first time... For no reason it just happened. Weird.

    Restarting Firefox did the trick.
  17. punodostres macrumors newbie

    Mar 17, 2010

    I closed from my browser (Firefox) and the space bar works again.
  18. numbir9 macrumors newbie

    Mar 25, 2010
    web browser interfering

    I had the same issue. Spacebar did not work for hand tool.

    I run firefox all the time. (currently on 3.6.2) along with illustrator cs4. Never been a problem for me.

    Problem occurred for the first time today. Just installed 4 gb ram (for a total of 8gb. restarted machine, opened firefox, opened illustrator. all of a sudden, spacebar/handtool did not work.

    so I did a websearch, found this forum, tried all the fixes, including resetting prefs. nothing worked. saw someone suggest to quit firefox.

    So I quit firefox, and bam, all good. I was even able to restart firefox, and it all still works.

    dont know if this has to do with the new ram install or what, but in any case, works now. I'd say try that before anything else.
  19. tags macrumors newbie

    Mar 27, 2010
    Browser or Preferences?

    Hey thanks to this forum I had my problem solved too.

    I just experienced it, space bar and everything else I do with those magic keys, except for the control key was not working. Usually a reboot seems to clear all problems. To my surprise it did not neither did the option/command/shift and rebooting Illustrator.

    After reading on, I tried both deleting the preferences and quitting out of Firefox. My Spacebar and constraining with shift key, etc. now WORKS!!!

  20. Lynxo macrumors newbie

    Jun 5, 2010
    It's in the Add-ons

    I just faced the same problem with the space bar not working as a quick hand tool, and after reading the thread, I tried to deactivate the latest plug-in I added to FireFox (Save Flash Video) and voilà! The problem was solved. No need to reset preferences of AI, or even quit FF.

    Thanks for the help.
  21. hellolovely macrumors newbie

    Jun 8, 2010
    Try quitting Hotmail...

    I had exactly the same problem in Illustrator CS3. I went through the various fixes listed above and nothing seemed to help.

    I then narrowed it down to being a Firefox problem, which only happens when I had running in the background.

    Now all I do it log out of Hotmail and the problem fixes straight away, no need to even restart Firefox.

    It worked for me, might work for you too!

  22. lpar69 macrumors newbie

    Jul 15, 2010
    Thank you!

    I experienced the same problem today with Illustrator CS4, no warnings.. it just appeared from nowhere and it is indeed frustrating. It disappeared when I quit Firefox. I was able to reproduce the problem when I restarted and run FF before Illustrator. Problem does not seem to appear if I start Illustrator before FF. Thanks again!
  23. design-is macrumors 65816


    Oct 17, 2007
    London / U.K.
    Opening up a tab and logging into a wordpress admin usually buggers it for me... In case that's useful to anyone :)
  24. sarno macrumors newbie

    Jun 18, 2009
    Firefox was the problem

    I turned off Firefox and Ill. CS4 works fine now. Told my co-worker about this and his problems with CS4 went away as well. Guess we'll have to stick to Safari until a fix comes out.

    Thanks to everyone for all of the helpful information in this thread!
  25. jag-mac-2010 macrumors newbie

    Mar 1, 2010
    Happens with Chrome too, so not browser based but web based? (probably Flash!)

    I started having the exact same trouble yesterday. So odd, and so unexplainable. So I restarted Illy and even my Mac, same deal. Today I opened the file again, and still no hand tool, shift contrain, etc. So I Googled it and found this thread.

    I tried a bunch of the above solutions (reseting Illustrator prefs, closing apps and helper apps from Activity Monitor, and even quitting Firefox) but to no avail.

    So it seemed everybody had this concensus that it was Firefox causing the issue, but when I quite firefox nothing changed (and I even waited to make sure it was all quit, and checked the activity monitor).

    Well, I actually browse the web from Google Chrome, and do my development from Firefox, so I had both Chrome with several tabs open and Firefox.

    I ended up closing one of my Chrome windows with like 13 tabs, and still no better. But then I closed my Chrome window with 31 tabs and voila - hand tool restored.

    I've even opened Chrome back up with the first 13 tabs, and all is well. So I'm betting the real issue is not the browser, but a script or something in one of the tabs I had open among the 31. It must be some Flash based bug (ironically) that is screwing up Illustrator.

    So if you have this trouble, it too and your not using firefox, just try closing out of all of your open web pages, no matter what browser.

Share This Page