Spaces doesn't work with mouse buttons. need help!

Discussion in 'Mac Basics and Help' started by fcamilleri, Oct 13, 2009.

  1. fcamilleri macrumors member

    Joined:
    Jun 7, 2009
    Location:
    In Your Mind
    #1
    I just reinstalled SL, and I cannot get spaces to work with mouse buttons. The mouse does work, and spaces works with keyboard keys. I really want it on my mouse though (mouse button #5).

    it is NOT an apple mighty, it's a microsoft X5 gaming mouse.
     
  2. colourfastt macrumors 6502a

    colourfastt

    Joined:
    Apr 7, 2009
    #2
    Then you'll need to get the proper SL driver from microshaft. But it's highly likely that the driver (if there is even one) won't support the accessory buttons.
     
  3. fcamilleri thread starter macrumors member

    Joined:
    Jun 7, 2009
    Location:
    In Your Mind
    #3
    uhhh.... why?

    I already have the buttons I would like to use mapped to expose and dash.

    no need for a driver, imo.

    it just isnt working with any mouse button period.
     
  4. MythicFrost macrumors 68040

    MythicFrost

    Joined:
    Mar 11, 2009
    Location:
    Australia
    #4
    So spaces is not working with any mouse button?

    Well, I assume then you've tried it on every mouse button, left/right/mid/any others.
    Why did you reinstall SL in the first place - I assume you were having problems, but what ones?
    Also, when you reinstalled did you do a clean install (and not install from Time Machine, upgrade, or migrate from an existing hard drive)?

    Kind Regards
     
  5. fcamilleri thread starter macrumors member

    Joined:
    Jun 7, 2009
    Location:
    In Your Mind
    #5
    I reinstalled SL just because I wanted a fresh install, no problems.
     
  6. UniHealthCare macrumors newbie

    Joined:
    Nov 7, 2009
    #6
    Mapping Spaces to the "open app" launcher

    Post below has helped me bring back the functionality of my Microsoft Mobile Mouse 3000 after downloading Microsoft's mouse driver:

    "Same problem on a Logitech MX 1000 mouse and my wired Mighty Mouse (though I just tried the mighty mouse after the problem was happening) Also, it doesn't interfere with spaces being launched by the mighty mouse app launcher. That basically brought back the functionality, so if you've got a MM, try that. (That is, under the possible actions for the button, select "Open ..." and then find and select the spaces.app in /Applications/Utilities/ )"

    Original post can be found here: http://discussions.apple.com/thread.jspa?threadID=1247554&start=15&tstart=45
     
  7. UJustGotPwnd macrumors newbie

    Joined:
    Apr 3, 2010
    #7
    Quick Fix for Spaces- Less than 10 seconds

    I had the same problem and here's the fix. Go into the system preferences and click on Mouse. Turn "ON" mouse key four and set it for spaces using the drop down list.

    From there go to Spaces in Preferences and Enable Spaces. Then assign it to button 4.

    Quick fix. Now mine works. For some reason button 4 gets turned off after doing an install. It doesn't matter if its an clean install or install from backup.
     

Share This Page