Spaces keyboard shortcuts

Discussion in 'Mac Basics and Help' started by ramparts, Jun 11, 2008.

  1. ramparts macrumors regular

    Joined:
    Jun 11, 2008
    #1
    I switched over to Mac last week (new Macbook with Leopard) and set up the Spaces keyboard shortcuts (control and arrow keys or number keys to switch between spaces), and they worked fine, but now for some reason they don't: when I do control-1, I go back to the 1st space, but it doesn't work for any of my other 3 spaces. Control-left arrow will get me from space 2 to space 1, but the rest of the control-arrow keys don't work. I'm in Firefox 3 now, and Control-2 brings me to the search window that I opened before I started this thread, while control-3 and control-4 just make my mouse disappear until I move it again. Any idea what happened to my Spaces shortcuts?
     
  2. Latro macrumors member

    Joined:
    Mar 23, 2008
    #2
    It sounds like you've set other shortcuts to the same cntrl + numbers as the ones assigned to spaces.

    You can check out this article on customizing your keyboard shortcuts. I believe there is also a way to reset all your shortcuts in system preferences. Doing so may fix the problem.

    Do you have shortcuts assigned in Firefox?
     
  3. TiffSunbacon macrumors newbie

    Joined:
    Oct 3, 2008
    #3
    I've got the exact same issue. New MacBook Pro; ctrl arrows navigated fine through the spaces panes at first, now they don't. Did you manage to sort it out?

    Thanks
     
  4. coonj macrumors newbie

    Joined:
    Aug 5, 2008
    #4
    Restart OSX

    doing a full reboot should fix the problem. I noticed this happened when I first got my mac (a few days ago) while I was installing software. Restarting fixed the issue.

    On a side note, I wish you could customize the keyboard shortcuts further, like using CMD+OPT+Arrow. I use the the arrow key combos when typing a lot
     
  5. flying-dutchman macrumors newbie

    Joined:
    Jul 28, 2009
    #5
    Old issue, but I have exactly this problem - does somebody have an idea, how to do this? It's actually very annoying to me, while typing: in Windows I need Ctrl+arrow, in InDesign (Mac) I need Cmd+arrow, in most other Mac Apps I need option+arrow - so none of them is available.
    Cmd+option+arrow would be perfect...
    Someone has an idea, for a workaround?

    Oops, just found it myself, was quite simple: change keyboard shortcuts in InDesign and take Cmd+arrow ;-)

    Cheers, FD
     
  6. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #6
    Also: check "Show Spaces in menu bar" and use the mouse.
     

Share This Page