Sparse Bundle Backup Problems

Discussion in 'macOS' started by explode90, Feb 4, 2014.

  1. explode90 macrumors newbie

    Joined:
    Feb 4, 2014
    #1
    Hi all. Once upon a time my former self (rookie) copied the contents of a time machine backup sparse bundle onto an external hard drive (didn't just copy the sparse bundle image) to 'back up the backup'. The folder's actual size is around 340gb, and I'm wanting to copy it onto a different drive as a part of my new years' 'consolidate, duplicate, archive, forget about' mission.

    The issue I have is that I can't copy it. I've tried using finder to copy the folder (both to another disk directly, or to a sparse bundle disk image) but when it adds up the size of all of the files it thinks there is > 9TB of data there. And of course there isn't enough free space at the destination and it errors out.

    I've tried using 'sudo cp -r /Source/Directory/ /Destination/Directory/' (sudo to bypass permissions) as well. This was slightly more successful; it copied one of the date-time folders and then error-ed away for a few hours. Then I couldn't delete the copied folder with finder (error saying the operation couldn't be completed), so I just deleted the whole destination disk image.

    I tried apple support, but didn't have much luck, which is understandable considering the uniqueness of the problem.

    As a last resort I could restore an entire hard drive with the contents of the drive with the problematic folder, and then delete everything else so as to have only copied what I'm trying to. I'm sure there's a better way though...

    My guess is that the aliases are what are breaking it. Within the sparse bundle of a time machine backup Finder normally understands to just look at the whole image's size, but without it knowing that it's actually a time machine backup full of aliases, it counts every file again for each subsequent date-time folder (even if further down the tree said files are actually unique).

    Any advice / tips / questions etc would be appreciated! I'll attach some screen grabs to help explain what's going on... (Please don't judge the backup convention, it will be the neatest, most organised backup you've seen. Just you wait.)
     

    Attached Files:

  2. explode90 thread starter macrumors newbie

    Joined:
    Feb 4, 2014
    #2
    Could anybody recommend somewhere better to post this?
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    cp stops when it hits a bad file/error. Try the same thing with the ditto command that will not stop at bad files.

    Something like:

    Code:
    sudo ditto -v /source/ /destination/
     
  4. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #4
    Another possibility is to use rsync. If you have a failing drive or intermittent problems reading the source, another invocation of rsync will pick up where the previous one left off.

    e.g.: rsync -avE /sourcedrive/folder /destinationdrive

    A.
     
  5. explode90 thread starter macrumors newbie

    Joined:
    Feb 4, 2014
    #5
    Cheers, will try one/both of these ideas and post results.
     

Share This Page