Speakers aren't working, headphone jack is, need help!

lovehaight

macrumors member
Original poster
Jul 22, 2008
68
0
Hi
speakers are not working, headphone jack is. Have tried reset pram, and reset the nvram..it worked fine this morning, at the moment it showing a circle with a slash, and is greyed out in the volume control in toolbar.. any help much appreciated!
PB 17'' PPC OS10.5
 

thegoldenmackid

macrumors 604
Dec 29, 2006
7,772
5
dallas, texas
Common problem on the MacBook Pro's. If it is, there will be a red light coming out of the audio out jack.

In that case, just unplug and plug your headphones until you get it to work. The actual cause of the problem to my knowledge is not known, but it's definitely a problem.
 

stylinexpat

macrumors 68000
Mar 6, 2009
1,792
3,265
I have tried a dozen or times..no luck, headphones work
Turn the device off that is plugged in and then restart the computer with the device plugged in. Then go to system preferences and go to sound to make sure settings are right. After that shut down computer and restart. When computer is shut down unplug headphone device before starting it back up. I had this happen to me a few times and it cleared up after doing the following. Something is definitely wrong. It does work eventually though.
 

lovehaight

macrumors member
Original poster
Jul 22, 2008
68
0
Yes it set to TYPE built in, however under NAME says Digital Out although there is no line out..looks ike the machine still thinks there is a line out..getting quite flummuxed.also tried fiddling with a toothpick
 

skorpien

macrumors 68020
Jan 14, 2008
2,339
0
If it's not the switch in the audio jack that's stuck and causing the issues, have you tried repairing disk permissions, resetting PRAM and SMC reset? Not sure if this will help but it couldn't hurt...
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.