Speakers aren't working, headphone jack is, need help!

Discussion in 'MacBook Pro' started by lovehaight, Nov 22, 2009.

  1. lovehaight macrumors member

    Joined:
    Jul 22, 2008
    #1
    Hi
    speakers are not working, headphone jack is. Have tried reset pram, and reset the nvram..it worked fine this morning, at the moment it showing a circle with a slash, and is greyed out in the volume control in toolbar.. any help much appreciated!
    PB 17'' PPC OS10.5
     
  2. thegoldenmackid macrumors 604

    thegoldenmackid

    Joined:
    Dec 29, 2006
    Location:
    dallas, texas
    #2
    Common problem on the MacBook Pro's. If it is, there will be a red light coming out of the audio out jack.

    In that case, just unplug and plug your headphones until you get it to work. The actual cause of the problem to my knowledge is not known, but it's definitely a problem.
     
  3. lovehaight thread starter macrumors member

    Joined:
    Jul 22, 2008
    #3
    I have tried a dozen or times..no luck, headphones work
     
  4. Rampant.A.I. macrumors 6502a

    Joined:
    Sep 25, 2009
    #4
    Try blowing it out with compressed air, assuming it's a piece of debris trapped in there.
     
  5. stylinexpat macrumors 6502a

    Joined:
    Mar 6, 2009
    #5
    Turn the device off that is plugged in and then restart the computer with the device plugged in. Then go to system preferences and go to sound to make sure settings are right. After that shut down computer and restart. When computer is shut down unplug headphone device before starting it back up. I had this happen to me a few times and it cleared up after doing the following. Something is definitely wrong. It does work eventually though.
     
  6. lovehaight thread starter macrumors member

    Joined:
    Jul 22, 2008
    #6
    tried it several times ..no luck.did you have to keep doing it?
     
  7. angemon89 macrumors 68000

    angemon89

    Joined:
    Feb 5, 2008
    Location:
    The place where Apple designs stuff
    #7
    Go to System Prefs > Sounds and make sure the input and output are set to "Built in"
     
  8. lovehaight thread starter macrumors member

    Joined:
    Jul 22, 2008
    #8
    Yes it set to TYPE built in, however under NAME says Digital Out although there is no line out..looks ike the machine still thinks there is a line out..getting quite flummuxed.also tried fiddling with a toothpick
     
  9. lovehaight thread starter macrumors member

    Joined:
    Jul 22, 2008
  10. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #10
    If it's not the switch in the audio jack that's stuck and causing the issues, have you tried repairing disk permissions, resetting PRAM and SMC reset? Not sure if this will help but it couldn't hurt...
     

Share This Page