Speakers not working, popping noise

Discussion in 'MacBook Pro' started by tvhargon, Jan 22, 2010.

  1. tvhargon macrumors newbie

    Joined:
    Dec 30, 2009
    #1
    Yesterday my speakers stopped working. It's not software based, the audio drivers are working properly. Whenever a sound that is over a certain volume is played, you can hear a pop come from the speakers. For instance, if I play a song that has fluctuating volume, every time the volume goes up, there's a pop, and every time it goes back down, there's a pop. The volume the computer is set to doesn't effect this. Even if it's muted, there's still a pop that's the same volume as if the volume is turned up all the way. Any ideas what could be causing this?

    (I took a video, I can upload it if that'd help)
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    To eliminate the possible software side of it, perform a Clean Install of Mac OS X. If the issue still exists, it is either the speakers or the main logic board, or both that have gone bad. I had a similar issue with my Mac and the logic board and speakers had to be replaced.
     
  3. tvhargon thread starter macrumors newbie

    Joined:
    Dec 30, 2009
    #3
    Thanks, I did do a clean install so I'll just take it into my friendly, neighborhood apple authorized repair facility. Thanks!
     
  4. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #4
    One thing that I just remembered....you might just try a simple PRAM and SMC reset, but I don't think that will fix this issue.
     

Share This Page