Speakers: Z5500 (optical) in Bootcamped Vista on an iMac?

Discussion in 'Mac Basics and Help' started by nicnic77, Jan 10, 2009.

  1. nicnic77 macrumors member

    Joined:
    Nov 18, 2007
    #1
    Hi all,

    I bought a pair of Logitech Z-5500 digital speakers today and have had no problem whatsoever getting them to work via an optical cable in OSX.

    Of course, I have no been so lucky with Windows Vista running under Bootcamp... I installed the Bootcamp drivers for Vista from the Leopard disk and it installed Realtek HD Audio Manager. Audio works fine through the internal iMac speakers with "Speakers" tab enabled as default and the optical cable unplugged, but setting "Digital Output" tab as default and enabling S/PDIF-In to S/PDIF-Out pass through mode and plugging in the optical cable I get no audio through the Logitech speakers!

    Can someone help me please?
     
  2. nicnic77 thread starter macrumors member

    Joined:
    Nov 18, 2007
  3. Yoshimo123 macrumors newbie

    Joined:
    Jan 11, 2009
    #3
    Hey,

    So I've had a similar problem as you do. I hook my macbook up to my tv and receiver to play movies relatively often. I use an optical-toslink cable from the headphone jack of the macbook into the receiver. While in OSX, everything runs perfectly, however in Vista, I get no sound whatsoever.

    My hypothesis as to why this doesn't work is simple. Apple has not released a driver that can allow the toslink hardware in the computer to work with Vista (or XP). That's why it doesn't work. My solution to the problem is to use a simple audio cable that splits the sound into left-right and plugs into the headphone jack.

    I have a question for you though. in your Z-5500 setup, how long were the cables to hook up each satellite to the main unit? Also can the cables be replaced with optical cables?
     
  4. stevey500 macrumors 6502

    Joined:
    Sep 8, 2004
    Location:
    Huntington, Utah
    #4
    In the audio mixer of windows ... click File>advanced settings or something similar and see if there is a check box for S/PDIF output.

    Get to the mixer by double clicking the speaker icon in the task bar (bottom right)

    Maybe change audio output devices to S/PDIF output.
     
  5. nicnic77 thread starter macrumors member

    Joined:
    Nov 18, 2007
    #5
    Thanks for the replies, I've not had any success yet as Windows just pissed me off too much yet again. If I solve it I'll let you know.
     

Share This Page