Specific apps terminate themselves consistently

Discussion in 'Mac Basics and Help' started by Plsendhelp, Jan 10, 2015.

  1. Plsendhelp, Jan 10, 2015
    Last edited: Jan 10, 2015

    Plsendhelp macrumors newbie

    Joined:
    Jan 9, 2015
    #1
    Specs: Version 10.9.5

    Processor: 1.4 GHz Intel Core i5

    Memory: 4GB 1600 MHz DDR3

    Graphics: Intel HD Graphics 5000 1536 MB

    My MacBook handles everything I do perfectly, runs games easily on medium and low settings, and hasn't shown ANY sign of having a virus or being corrupted.

    I purchased WoW a few months ago and enjoyed it for about two days before it started closing itself ~5 seconds after being opened without any crash report or warning. It was as if I was force quitting it right after I opened it (didn't freeze up just smoothly and instantly shut down). I searched through the console and found nothing except for a small blurb about accessibility API each time it closed. I gave the app permission to control my computer via "Security & Privacy" in system preferences but that did nothing (it was the only fix I could find online, reinstalling and all the other basic steps did nothing). I was pissed that I had wasted $20.00 for a month of a game that I couldn't play, but I moved on figuring it was some freak incident as nobody else online seemed to have experienced the same thing and it had never happened before.

    Fast forward three or so months and I purchase "Borderlands 2" and a bunch of its DLC for cheap during the Steam Christmas sale. Game worked perfectly on lowish settings for about one day and then the exact same thing happened. I open the game, get to the launcher which closes in about ~4 seconds, or if I manage to click "Launch Game" fast enough it closes the game before the cinematic even ends. Reinstalling it on Steam fixed it for ONE opening, closed it and reopened and the problem resumed.

    I am at a complete loss, nobody seems to have had this issue online and the Gearbox forums didn't respond to my post. Other games work fine from steam (CS:GO, Binding of Isaac, Garry's Mod, Witcher series, etc). No other apps do this.

    If anyone has ANY suggestions besides reinstalling OS (not an option) please share them. It's entirely possible that someone set my computer up to do this via some sort of IT software or hidden settings (computer was technically my schools before I purchased it from them and I have prank-heavy friends who know their way around macs) but I'm flabbergasted. Its so specific and it always happens the same way, without any crash message.


    1/9/15 9:46:47.745 PM com.apple.launchd.peruser.719477396[249]: (com.aspyr.borderlands2.steam.95424[2975]) Exited: Terminated: 15


    This is the ONLY message I could find in console after it closed itself, and it only appeared after I had opened BL2 via its main folder instead of the Steam app.

    Please let me know if their is anything I should try or that you need to know or where else I should look for crash messages. If you can find a permanent fix for these I'd be happy to give you whatever you want in the game or even gift you a game on Steam.



    EDIT: Also feel that I should add that I had torrented the game a few months prior to purchasing it and was unable to play it for the exact same reason but assumed the torrent was broken.

    EDIT: Just tried renaming the actual app from "Borderlands 2" to "Shoes" (weird, I know) and the launcher which normally would close didn't close. It broke the game for obvious reasons but I'm definitely thinking that my computer is set up to instantly terminate certain apps by name (maybe my school's IT had it that way and didn't remove it) so if anyone knows of any IT apps or programs or setups that could do that maybe its that.
     
  2. Plsendhelp thread starter macrumors newbie

    Joined:
    Jan 9, 2015
    #2
    Fixed it!

    So nobody had anything to say but I've dedicate about 5 hours to this now and found what seems to be a permanent solution. There was a program/app on my computer leftover from the school's IT department called Lanrev and Absolutemanage or something. I removed all the files and no longer am experiencing this problem. LMK if you want to know where exactly to find these files or if you have the same problem.
     

Share This Page