Spectrum ipv6 Apple Music stops working.

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by tonyr6, Jul 8, 2019.

  1. tonyr6 macrumors 65816

    tonyr6

    Joined:
    Oct 13, 2011
    Location:
    Brooklyn NY
    #1
    I notice when I turn on ipv6 on Spectrum account iTunes won't load anything and on my phone AM is slower than dirt just giving me gray boxes after a few minutes slowly loading artwork. This has been going on for three weeks now. Not a peep anywhere from Apple or Spectrum. I even hooked it up directly to the computer and it won't work with ipv6 connecting. I also changed DNS even using the native DNS still does not work.

    Also if I turn off ipv6 through my router my cable modem gives me no such option then iTunes and the Apple Music app loads fine.
     
  2. Ledgem macrumors 68000

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #2
    For what it's worth, I use Spectrum (previously Oceanic Cable, also known as Time Warner Cable) and have IPv6 configured... no problems with Apple Music. Spectrum is still integrating here, so not sure if that has anything to do with it.

    Do you have any other IPv6 problems? If you use https://ipv6-test.com what is your score, and is IPv6 "native"?
     
  3. tonyr6 thread starter macrumors 65816

    tonyr6

    Joined:
    Oct 13, 2011
    Location:
    Brooklyn NY
    #3
    It's still broken I found running the iTunes Diagnostic tool I get "Secure Link to iTunes Failed" error. It just plain gives up and won't play or load anything with IPv6 on. I have to turn it off again because of that POS iTunes.
     
  4. Ledgem macrumors 68000

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #4
    Did you use the IPv6 test? I'm wondering if there's something with the way IPv6 is set up in your router that's causing the problem.
     
  5. tonyr6 thread starter macrumors 65816

    tonyr6

    Joined:
    Oct 13, 2011
    Location:
    Brooklyn NY
    #5
    The IPv6 test passes with 10/10 however iTunes is DOA when it is turned on. It is also DOA if I connect the modem directly to the computer so it is not the router.
     
  6. Ledgem macrumors 68000

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #6
    Well, one oddity - the test is out of 20 for me, not out of 10. Not sure what that means about your configuration.

    Is your modem a combo modem/router (like most ISPs supply), or a pure modem? Did you adjust IPv6 settings on the Mac side, or is it only set up on the modem?
     
  7. tonyr6 thread starter macrumors 65816

    tonyr6

    Joined:
    Oct 13, 2011
    Location:
    Brooklyn NY
    #7
    I would try an IPv6 tunnel like Hurricane Electric but that will brake Netflix.
     
  8. Ledgem macrumors 68000

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #8
    How do you have IPv6 configured? Is it on your Mac end, or on your modem/router (if that's what you have), and/or on your router? It sounds like the problem lies in your configuration of IPv6.
     
  9. tonyr6 thread starter macrumors 65816

    tonyr6

    Joined:
    Oct 13, 2011
    Location:
    Brooklyn NY
    #9
    After a small internet outage I tuned on IPv6 and now it is working fine with Apple Music. Spectrum must have been blocking something on my end but I could have not been the only one affected or I guess there are not many AM subs using Spectrum or using IPv6.
     

Share This Page

8 July 8, 2019