Speed up macOS Sierra animation

Discussion in 'macOS Sierra (10.12)' started by duderman67, Sep 21, 2016.

  1. duderman67 macrumors newbie

    Joined:
    Jul 15, 2013
    #1
    Hello guys! I finally upgraded to macOS Sierra and almost horrified by the new and very slow mission control animation. So is there an actual way to speed it up?
    I found this Terminal command "defaults write com.apple.dock expose-animation-duration -float 0" which allegedly should speed animation but it seems to not working in Sierra. I tried different floats (0.5, 0.2, 0.1, 0.05 etc) and didn't see any changes at all.
     
  2. h9826790 macrumors G3

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    Sounds something wrong. My mission control speed is very normal. Not lightning fast, but reasonable fast animation.
     
  3. old-school macrumors 6502

    Joined:
    Sep 2, 2009
    Location:
    UK
    #3
    They have changed the speed to inertial speed depending on how quickly you gesture on the trackpad. The mission control button seems to be an average speed though.
     
  4. moophone macrumors member

    Joined:
    Nov 3, 2014
    #4
    In the same boat. navigating between spaces is way too slow, I'd rather have no animation since its something I do all the time
     
  5. MikhailT macrumors 601

    Joined:
    Nov 12, 2007
    #5
    Turn on Reduce Motion in the SysPrefs > Accessibility, it will speed it up by a huge factor.
     
  6. Takuro macrumors 6502

    Takuro

    Joined:
    Jun 15, 2009
    #6
    Are you talking about a slow but smooth animation or one thats choppy? If it's choppy, "defaults write com.apple.dock expose-animation-duration -float 0" will only mask the problem because you're setting the animation duration to 0 seconds, which means the animation is effectively disabled.

    I had a few issues with animations like window maximization and mission control being choppy after upgrading from 10.11.6 to 10.12.0 yesterday. I ended up booting into the recovery partition and installing 10.12.0 again over my existing install while retaining my user files. Somehow this fixed it, as well as a lot of other completely unrelated issues.
     

Share This Page