Spell Check in Pages '08

Discussion in 'Mac Apps and Mac App Store' started by OldManJimbo, Sep 20, 2007.

  1. OldManJimbo macrumors 6502

    OldManJimbo

    Joined:
    Jun 1, 2004
    Location:
    California Coast
    #1
    Long time power user of MS Word - giving Pages a serious try. SIX DAYS left on the trial offer.

    Can't figure out the Spelling function -

    Words that are clearly misspelled don't get a little red squiggle under them. And when I click "check spelling" some of these mistooks are ignored.
    I have selected "check spelling as you type" but I have my doubts that it is working as I'm a horrible speller and it's not catching my goofs.
    Can't find a place to set the dictionary.

    I see Pogue has a Missing Manual for '08 coming in January, but I don't want to wait that long.
     
  2. Badradio macrumors 6502

    Joined:
    Aug 19, 2004
    Location:
    Manchester
    #2
    Can you post some examples of words you think are misspelled? Most of the time, the word you think is incorrect is actually a word - albeit an archaic, rarely used word - that the spellcheck is ok with. I've found the Pages spellchecker to be pretty good so far.
     
  3. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #3
    I've never had a problem with it, though it can take a while for the spell-checker to catch up when you open a long document.

    This is also the very same spell checker which is shared by every native Mac application (Safari, TextEdit, Mail, etc), so it should be very easy to determine if it's working properly.
     
  4. OldManJimbo thread starter macrumors 6502

    OldManJimbo

    Joined:
    Jun 1, 2004
    Location:
    California Coast
    #4
    In a simple one-page letter I was writing this morning, the following words were not seen as incorrectly spelled - no little red squiggle:

    Newsletteer (extra "e")
    Likly (missing "e")
    elemtns - should be "elements"

    I have selected "check spelling while I type" and these three words all show up with a squiggle under them when I paste them into MAIL - so I wonder if:

    I have something not set properly on Pages OR perhaps the trial version doesn't have a full dictionary.
     
  5. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #5
    I'd check the settings again in Pages, though I can hardly imagine what could go off if you set it once already.

    Pages accesses the universal OSX dictionary, so you get it in the Pages trial version too. I'm using the trial versions of Pages 3.0 at the moment, and the spell check works fine.
     
  6. dsnort macrumors 68000

    dsnort

    Joined:
    Jan 28, 2006
    Location:
    In persona non grata
    #6
    I do know that under the trial version some elements of iWork do not work, can't imagine spell check being one of those.
     
  7. OldManJimbo thread starter macrumors 6502

    OldManJimbo

    Joined:
    Jun 1, 2004
    Location:
    California Coast
    #7
    Yeah - I can't imagine it is supposed to be as "dumb" as it seems on my end. When I select PREFERENCES there is only a handful of options. The PREFs screen only has two options at the top - General and Auto-Correction. This alone seems odd to me, as most Apple apps have a slew of options in the PREF screen.

    I can't find anyplace to set the default language or spellcheck defaults.
     
  8. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #8
    Ah, I see the problem. This setting is not under preferences (where it probably should be). It's under the menu Edit/Spelling.
     
  9. Badradio macrumors 6502

    Joined:
    Aug 19, 2004
    Location:
    Manchester
    #9
    I thought the downloaded trial was the complete version, and that you could simply activate it using a purchased code? I can't verify that though, as I was completely anal and deleted it to reinstall the version from the retail disk.

    As for the op's issues - that could be a catch-up issue like IJ Reily said.
     
  10. OldManJimbo thread starter macrumors 6502

    OldManJimbo

    Joined:
    Jun 1, 2004
    Location:
    California Coast
    #10
    In that setting, I have selected "Check Spelling While I Type" and yet it doesn't.

    I have purposefully entered incorrectly spelled words and it doesn't find them. And when highlighting errors and clicking "Check Spelling" it is "dumber" than I am and doesn't catch the mistakes.

    I am perplexed - to say the least.:confused:
     
  11. Mechcozmo macrumors 603

    Mechcozmo

    Joined:
    Jul 17, 2004
    #11
    I have sometimes founds that the spellchecker forgets to check my spelling, but all it takes is to uncheck/recheck the "Check Spelling As You Type..." option and it works just fine. I've been using the built-in dictionary for years, and it always has caught misspelled words right after I've typed them.
     
  12. OldManJimbo thread starter macrumors 6502

    OldManJimbo

    Joined:
    Jun 1, 2004
    Location:
    California Coast
    #12

    Hmm - that doesn't seem to fix the problem either.

    I'm not one of these people who tries to find things wrong with an app - I really want this to work so I can stop using MSWord when they bring out that stupid 2008 version with the "ribbon" -

    But this has me freaked out - I am terrible speller and really need an app that covers my behind.

    Does anyone know of a website with detailed "how to" stuff on iWork '08?
    I am convinced this is something that I have set improperly, but can't determine what it might be.

    I've repaired permissions - I wonder if there might be a plist file that needs to be deleted?
     
  13. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #13
    My next suggestion would be to delete the preference file, which is:
    com.apple.iWork.Pages.plist
     
  14. OldManJimbo thread starter macrumors 6502

    OldManJimbo

    Joined:
    Jun 1, 2004
    Location:
    California Coast
    #14
    Done - we'll see what happens today. I have three days remaining on the trial.

    My prime motivation for making the switch to Pages is that horrid "ribbon of death" being shown for the Word update - I have some friends with PCs and that stupid thing drives me crazy - they've added multiple steps to the simplest of tasks.
     
  15. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #15
    If it works you should know right away. Just remember to reset "Check Spelling as You Type." Let us know if this fixes the problem. I'm very curious.
     
  16. OldManJimbo thread starter macrumors 6502

    OldManJimbo

    Joined:
    Jun 1, 2004
    Location:
    California Coast
    #16
    :):cool::D

    Deleting the plist file seems to have done the trick - I fired up Pages and started tying away with my usual reckless abandon and the page was full of little red squiggles - NICE.

    Question - does the "Check Spelling as I Type" selection remain as a default or do I need to check that every time I open a document?
     
  17. dpaanlka macrumors 601

    dpaanlka

    Joined:
    Nov 16, 2004
    Location:
    Illinois
    #17
    Pages got it for me:

    Picture 1.png

    Thats correct.
     
  18. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #18
    Excellent. The selection should stick from now until the Earth's crust cools. Beyond that, no guarantees. ;)
     
  19. syverex macrumors newbie

    Joined:
    Jul 30, 2008
    #19
    but, no auto-correct as you type?

    my mum was ranting to me that pages do not have a auto correct as you type function, it is in MS Word, but not in Pages?
    and i do not mean that red line thingy only, as in, correct the whole word automatically
     
  20. .adam macrumors regular

    Joined:
    Nov 20, 2007
    #20
    Your Mum is right, my friend. Infuriating, isn't it?
     
  21. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #21
    Infuriating in a way, since you're both wrong. Look under Preferences for the Auto-correct tab.
     
  22. syverex macrumors newbie

    Joined:
    Jul 30, 2008
    #22
    but which one is it? i have ticked all of them, but no auto-correct as you type function
     

    Attached Files:

  23. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #23
    You select the words and symbols you want auto-corrected from the list. If you need more words to be auto-corrected, add them to the list.
     
  24. syverex macrumors newbie

    Joined:
    Jul 30, 2008
    #24
    Thanks!

    oh...thanks for the info and the quick reply!
    but to do all this is a little, tedious..isn't it?
     
  25. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #25
    That depends -- what do you need it to do? I've got it set so it corrects common typing errors, such as inversions, and some of the symbols. I don't think I could stand having Pages change my proper nouns into the closest word it could find in the dictionary. That would be truly tedious!
     

Share This Page