Spell check switches to French... space & semicolon

Discussion in 'Mac Basics and Help' started by henryg, Nov 24, 2008.

  1. henryg macrumors newbie

    Joined:
    Nov 24, 2008
    #1
    In one document in MS Word 2004, the language keeps reverting to French. I try resetting both the default language and the language choice as English (Tools > Language...), however, rather quickly it reverts back to French. This messes up the spell check. What can I do to keep it on English?

    (With a google search, I did find a 2005 post that mentions this as a systemic problem. But that forum didn't seem to offer a solution:
    http://techrepublic.com.com/5208-11192-0.html?forumID=52&threadID=185046
    Has this been settled elsewhere?)

    Second problem, perhaps related. MS Word automatically corrects some spelling as I type. However, in the document with the French problem, the text is being corrected in a weird way. It's not accepting a semi-colon ; next to a word. Instead, it inserts a space between the word and the semi-colon.

    What's that all about and how do I change it? Are these problems related?

    thanks much.
     
  2. scienide09 macrumors 65816

    scienide09

    Joined:
    May 5, 2007
    Location:
    Canada
    #2
    I'm not sure what's causing your problem, but yes, the second is related to the first.

    In French, any two-part punctuation mark demands a space before and after. So things like colons, question and exclamation marks, and others want that whitespace.

    I hope you find a solution.
     
  3. bezaire macrumors newbie

    Joined:
    Jan 24, 2009
    #3
    Spell check switching to french

    I had the same problem. I just tried this fix and it seems to work.

    Try selecting all the text and then going to Tools->Language and selecting English. You can also choose this as a default for all of your future documents.
     
  4. erstwhilepo macrumors member

    Joined:
    Jan 4, 2009
    Location:
    Midwest
  5. Teresah2907 macrumors newbie

    Joined:
    Jul 12, 2009
    #5
    Same problem - Reference tools keep reverting dictionary and thesaurus to french

    Hi There,
    Newish to Mac and this problem has just occurred, should I try a virus scan??
     
  6. Barty Fartslast macrumors newbie

    Joined:
    Jul 27, 2009
    #6
    The solution to the problem (at least with Word 2011) is to select ALL the text in the document, then go to Tools-->Language and set it to the one you want (in my case US English). I also noticed that the "Do not check spelling or grammar" had a dash in it (not clear and not a check mark) so I checked it then unchecked it just to make sure it was "cleared" completely.

    This resolved the issue of Word trying to force all my spelling corrections to French.

    I think this problem originated because I was using a document that might have ORIGINALLY been authored by someone in Montreal, QC where they probably "default" to French, but she authored the document in English. Many years later (and probably three or four versions of Word later), the document still thought it should be French.

    sooo glad I finally figured out this problem!!!
     

Share This Page