Spellcheck problems in Microsoft Word 2008

Discussion in 'Mac Apps and Mac App Store' started by kevzy, Apr 16, 2008.

  1. kevzy macrumors member

    Joined:
    Jan 27, 2008
    #1
    Hey guys. I'm having some problems with the spellchecker in MS Word 2008. It's driving me crazy and I'd really appreciate some help.

    When I open up a new word doc (doc 1) and start typing randomly with loads of spelling errors the little red line does not appear under the mis-spelled word. When I Manually select spell check it tells me that there are no mistakes even though there blatantly are. If I open up a new blank doc (doc 2) and begin typing away again the same mis-spelled words, the red lines appears as it normally should.

    This is where it gets weird.......In doc 2 if I go into preferences>spelling and grammar, The boxes, "check spelling as you type" and "always suggest corrections" are ticked under both the spelling and grammr sections. If I then go into the same preferences for doc 1 the same boxes are ticked under the spelling and grammar sections however the grammar section is greyed out so I can't change the settings.

    I am currently typing my thesis so having a wacky spell check is driving me insane. What I have been doing is opening a new doc then opening another new doc (doc 2) and typing in that however I have also noticed that the spell check doesn't always seem to work.

    Apologies for the long post. Any help would be greatly appreciated. Thanks in advance for replies.
     
  2. kevzy thread starter macrumors member

    Joined:
    Jan 27, 2008
    #2
    bump bump bump

    Anybody.....

    I would really appreciate some help on this.

    Am I doomed to an eternity of spelling mostakes.

    See...it's happening already:D
     
  3. CN123 macrumors newbie

    Joined:
    Aug 2, 2008
    #3
    Spell check in Word 2008 on Apple Computers

    I finally figured out this method of making the spellcheck work:

    1. Highlight the entire text in the document you want to check.
    2. Click the 'Tools' Option on the menu bar.
    3. In the drop down menu under 'Tools' click Langauge. Then select 'English UK' or 'English US' as appropriate. Click OK. this should result in the red line appearing under spelling mistakes in the document.
    4. Then click the 'Tools' option again and click on 'Spelling and Grammar' in the dropdown menu. You should then see suggestions to correct each spelling mistake (Make sure the cursor is on the word you want to correct before clicking 'spelling and grammar').

    The Autocorrect function seems to be completely useless.
    :)
    CN123
     
  4. askirkland macrumors newbie

    Joined:
    Aug 1, 2008
    #4
    Fix did not work for me

    That fix / workaround did not work for me. Has anyone else had this issue and/or figured out a fix?
     
  5. djwaldow macrumors newbie

    Joined:
    Mar 22, 2009
    #5
    You rock (it worked)

    Love google! I searched, came upon this page, read and followed the steps in your post and BAM! It workd.

    Thank you.

    DJ Waldow

     
  6. sennejm macrumors newbie

    Joined:
    May 26, 2008
    #6
    If the above-described solution does not seem to work, try saving the document, quitting word, and then re-opening the document. This worked for me.
     
  7. fordieuk macrumors newbie

    Joined:
    Oct 21, 2009
    #7
    Spell checker problem resolved

    Hi, I had the same problem and I managed to sort it clicking on 'tools' then 'spelling and grammar' then when the spell check box comes up click on options button at the bottom, then make sure the first box under the spelling heading is ticked and it is 'check spelling as you type' this should solve your problem.

    regards
     
  8. jeaimehp macrumors newbie

    Joined:
    Jan 26, 2010
    #8
    Thank you so very much!! Worked perfectly!
     
  9. ribeto macrumors newbie

    Joined:
    Apr 18, 2010
    #10
    This totally fixed my problem. Thanks a lot
     
  10. ZestySea macrumors newbie

    Joined:
    May 19, 2010
    Location:
    Sydney, Australia (near Cronulla)
    #11
    You guys are great! thanks

    :p I had the same problem - tried variations on the theme as my original doc was open office. saved, closed and opened (no change)

    saved as docx, closed and reopened new file (no change)
    went into tools languages - there was a horizontal line in the check-box "do not check spelling" - clicked it, went to a tick, clicked again, changed to a clear box - set the language as described above and the spell check and grammar is working great now - thanks!!
     
  11. sebastianduan macrumors newbie

    Joined:
    Jun 10, 2010
    #12
    check box

    It didn't work for me when first tried. The check box automatically didn't tick though, just had a - sign. When I updated to a tick, it worked. Does that help?

     
  12. Honor3 macrumors newbie

    Joined:
    Aug 23, 2010
    Location:
    Australiaaaah
    #13
    Tools > Pick The other English then you have > Press okay > write Gibberish > You should get red lines > Tools > English you want > Now when you write Gibberish and anything else should be in red and spelling suggestions should be available..
     
  13. KatherineB macrumors newbie

    Joined:
    Sep 28, 2010
    #14
    Problem with MS Word 2008

    Hi everyone,

    I am having a similar issue to the issues mentioned above, only when i go into preferences, the spelling and grammer section is faded and can not be clicked on or activated at all.... what can I do? :(

    The Language>Tools> solution above does nothing, mistakes are definitely occurring however I appear (?) to be missing the spelling function all together..... very frustrating!!!

    Can anyone help?
     
  14. OurManAtTheUN macrumors newbie

    Joined:
    Mar 22, 2011
    #15
    Found the problem

    It seems that regardless of language, because I am forever having to change my Office from English US to UK. This is what you also have to do.

    Select all the text.

    Tools>Spelling and Grammar> at the bottom of panel, Options...

    tick the 1st box 'check spelling as you type'

    Hope this helps, it helped me.

    ;0j
     
  15. canoncola macrumors newbie

    Joined:
    May 6, 2011
    #16
    Fix!!! Fix!!! Fix!!!

    I can't check spelling or grammar.:eek::mad:

    Cause: Proofing tools are not installed.:confused::(

    Solution: Install the proofing tools from the Office 2008 installation disk.:eek::cool:

    Print this information or write down the following steps, and then close the Microsoft Word Help window.

    On the Word menu, click Quit Word.

    Insert the Office 2008 installation disk into your computer's DVD drive.

    Open the Office 2008 installation disk, and then open the Office Installer.

    Follow the steps in the Office Installer, and on the Installation Type screen, click Customize.

    In the Package Name list, click the arrow next to Microsoft Office 2008, and then click the arrow next to Proofing Tools.

    Select the check boxes next to the proofing tools that you want to install, and then click Install.

    Note If you do not see the language that you want, it is not available in Office 2008 for Mac.
    :D:D:D:D:D:D:D:D:D:D:D:D:apple::p
     
  16. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #17
    Did you happen to notice the 2nd link in post #9, posted a year ago?
     
  17. mackiwilad macrumors member

    Joined:
    Sep 21, 2007
    Location:
    Ask the Goverment!
    #18
    Me too. Thanks dude!
     
  18. LenaH macrumors newbie

    Joined:
    Dec 1, 2010
    #19
    Spellcheck problems in Microsoft Word 2008

    i went to edit>spelling>check spelling as you type. i turned 'check spelling as you type' off then turned it back on and it worked! hope this helps.
     
  19. ChainsawBuddha macrumors newbie

    ChainsawBuddha

    Joined:
    Jul 2, 2008
    Location:
    Texas
    #20
    caps lock

    I noticed that this happens when you have caps lock on.
     

Share This Page