Spelling preferences

Discussion in 'Mac Basics and Help' started by scarabrae, Jul 9, 2008.

  1. scarabrae macrumors newbie

    Joined:
    Mar 18, 2008
    #1
    Hi

    I am from the UK and have a macbook. Despite setting my Region to the United Kingdom, under System Preferences>International>Formats, my spell checker continues to want to correct my spelling to USA spelling when using Pages or TextEdit.

    For example I get an spelling mistake highlight when I type "colour" but not "color", etc.
     
  2. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #2
    To do this system wide you have to use British English rather than English :)rolleyes:). To do this go to System Preferences - International - Language - Edit List

    Then check the box by British English then OK and put it at the top of the list.

    Best to log out and back in again afterwards.

    If that didn't work properly then


    When in TextEdit got to Edit - Spelling - Show Spelling and Grammar

    Then where it says English change that to British English.


    For Pages

    To make sure that the correct language is selected, click Inspector in the toolbar, click the Text Inspector button, and then click More. Select a language from the Language pop-up menu.
     
  3. scarabrae thread starter macrumors newbie

    Joined:
    Mar 18, 2008
  4. swttemperedx macrumors newbie

    Joined:
    Jul 12, 2009
    #4
    spelling preferences

    my macbook suddenly stopped correcting my spelling whenever i type in boxes on webpages. you know, the squiggly red line underneath misspelled words? how do i get that option back? thanks.
     
  5. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #5
    Are you using Safari?

    If so make sure that the following option is checked:

    Picture 3.jpg
     
  6. macgrl macrumors 65816

    Joined:
    Jul 17, 2008
    #6
    Great question. Changing my spelling settings was something that i had been meaning to get around to for ages. No I have finally done it :)
     

Share This Page