Spinning beach-ball for iPhoto 09

Discussion in 'Mac Apps and Mac App Store' started by coachburke, Jan 30, 2009.

  1. coachburke macrumors newbie

    Joined:
    Oct 6, 2008
    #1
    I have an Aluminum macbook 2.0 and just upgraded to iLife 09. Every time I open iPhoto 09 I get the spinning beach-ball for 1 to 2 minutes. Is this happening to anyone else? :(
     
  2. Chris Grande macrumors regular

    Chris Grande

    Joined:
    Jun 17, 2003
    #2
    Are you getting that and then your library opens or does it quit? I've noticed this as well (long time to open) seems random. Looks like they also took out the "Loading Photos…" message. Seems to only happen on my main library with 6,500 photos, I have another with about 1,500 that opens rather fast.
     
  3. drewster macrumors member

    Joined:
    Aug 4, 2008
    #3
    Same thing happened to me on upgrade from 2008 - partly I think loading the new places, and faces features for the first time, partly loading the welcome screen. However, I found trashing the preferences files, and then restarting iPhoto seemed to clear it up. YMMV.
     
  4. coachburke thread starter macrumors newbie

    Joined:
    Oct 6, 2008
    #4
    It will open, then after about 10 sec. the ball will start and last over a minute. After that there is no problem with it.
     
  5. SeanM macrumors newbie

    Joined:
    Aug 25, 2007
    Location:
    USA
    #5
    I'm having the same issue as you - after disabling my Airport I noticed that it no longer beach-balls after startup so I realized it was a network-related issue.

    I made a few changes in the Preferences of iPhoto - under the Sharing tab I unclicked "Look for shared photos" and "Share my photos" and then under the Web tab I set it to "Check for new published photos" to manually. After that it worked 100% fine and launches instantly.

    I'm almost positive the issue is related only to the "Look for shared photos" checkbox. Not really a great "solution" but it'll have to do for now until Apple releases a software update or something.
     
  6. mrkgoo macrumors 65816

    Joined:
    Aug 18, 2005
    #6
    It is definitely network related, but is not any specific thing, because I tried turning all internet stuff off in iPhoto and I still get the beachball. Turning off airport altogether stops it. If you check your console logs, about 30 seconds after loading, it informs you that the iPhoto process is being monitored.
     
  7. coachburke thread starter macrumors newbie

    Joined:
    Oct 6, 2008
    #7
    I was about to post the same thing. Yesterday My brother in-law and I tried messing around with the sharing preferences and unchecked look for shared photos and it looks like it worked. But before that iPhoto crashed, so we reported it to Apple with some nasty comments. Hopefully they will update soon!
     
  8. mrkgoo macrumors 65816

    Joined:
    Aug 18, 2005
    #8
    I don't think it is that. Mine beach balls about 10-20 seconds after loading, for about 5-10 seconds regardless of that option (or other web options).

    It's not mission critical, but a small annoyance. Well, considering I wait 30 seconds for a lot of shareware apps to open, I don't mind.

    I'm convinced it has something to do with places and connection with the places server. When you first load, it contacts Apple or something to link with their location server. Why do I think this? Well, check out the preferences advanced pane - this always gives me a short period while accessing, and changing the places settings.
     
  9. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #9
    Just wanted to share the I too turned off the Look for shared photos option, and my iPhoto doesn't beachball at startup anymore.

    -Kevin
     
  10. jalyst macrumors regular

    Joined:
    Aug 17, 2009
    #10
    Made no difference for me, still getting the bloody annoying beach ball, & I haven't even got anything in the freaking library yet!
    Approx. 2 sec after launch, it starts to beach ball, & that goes for approx. 15 secs...
    I have a late 09' Mac Mini, but not the official max. of 4GB ram, I have 8GB, + a fast modern day 6G SSD! (which is kinda wasted on the Mini's 3G interface)
     
  11. jalyst macrumors regular

    Joined:
    Aug 17, 2009
    #11
    Tried rebuilding the library using various doco'd methods, as well as creating an entirely new one, still the same ridiculous problem. Even tried removing plist file from ~/Library/Preferences & launch the app, made no diff, just recreated the plist file & continued with the same issue.

    Can't believe I've had to waste so much time on this & I haven't even started to heavily use the app...
    If it was massive DB filled with thousand of photos then sure I'd understand, but this is a completely fresh DB!

    :mad:
     

Share This Page