Spinning wheel forever after 10.5.2 update

Discussion in 'macOS' started by Firestone, Mar 3, 2008.

  1. Firestone macrumors newbie

    Firestone

    Joined:
    Mar 3, 2008
    #1
    Hi....

    My girlfriend got a problem with her Macbook after installing the 10.5.2 update. The wheel on the bootscreen just keeps spinning forever and nothing more happens.

    Have tried the following things:
    Boot to safe-mode (SHIFT)
    Boot to DVD and repair permissions
    Reset PRAM

    After booting into verbose mode she can see the following messages flying over the screen repeating itself forever:

    SetDomainSecrets: mDNSKeychainGetSecrets failed error
    mDNSPlatformInit_Setup: SecKeychainAddCallback failed 1
    Daemon start: mDNS_Init failed 1
    Daemon start: mDNSDaemonInitialize failed

    I was hoping that there was a simple solution for this issue instead of doing an "Archive and install".....

    Have searched everywhere for this issue, but nobody seemed to come up with a good solution.
     
  2. forgottensoft macrumors regular

    Joined:
    Dec 31, 2007
    Location:
    Vermont, USA
    #2
    hmmm, I would try removing your computer from all peripherals (including internet). It seems its having an issue with DNS. Although I have a feeling that you might have to do an archive and install because that is a system level problem.
     
  3. Firestone thread starter macrumors newbie

    Firestone

    Joined:
    Mar 3, 2008
    #3
    She tried that... even tried to use the computer without the battery, connecting only the power-adapter.

    Ended up with moving the following two files from /System/Library/LaunchDaemons/

    com.apple.mDNSResponder.plist
    com.apple.mDNSResponderHelper.plist

    The system now boots, but she says that she got problems with getting passwords saved to the keychain because of this and some other small issues too.
    Anyway, this was just temporary to get the system to boot because she had some assignments at school she needed to finish.
    Will perform a clean install on the machine as soon as she gets home.

    Thanks for answering anyway :)

    Problem solved ...well sort of...
     
  4. percusso macrumors newbie

    Joined:
    Mar 22, 2008
    #4
    Here's how I fixed the problem completely without having to do a clean install:

    1. Mount the hard drive on another Mac using Target Disk Mode

    2. Go to /System/Library/LaunchDaemons/ and move the following files to the Desktop:

    com.apple.mDNSResponder.plist
    com.apple.mDNSResponderHelper.plist

    3. Restart the Mac

    4. Move the two files from the Desktop back to /System/Library/LaunchDaemons/

    5. Repair permissions using Disk Utility

    6. Reinstall Mac OS 10.5.2 Combo Updater

    Problem solved! Machine now works as normal :)
     

Share This Page