spinning wheel/freezes after replacing crashed HD (older machine)

Discussion in 'iMac' started by williah, Jan 10, 2014.

  1. williah macrumors newbie

    Joined:
    Jan 9, 2014
    #1
    have an older machine, an iMac 6.1

    Model Name: iMac
    Model Identifier: iMac6.1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.33 GHz
    Number of Processors: 1
    Total Number of Cores: 2
    L2 Cache: 4 MB
    Memory: 3 GB
    Bus Speed: 667 MHz

    So a few months ago my 750 gb internal HD crashed. I had no backup (I know).

    I replaced it with a 1 TB internal HD. I reinstalled Leopard, then upgraded with my Snow Leopard disk. I didn't install SL directly cause I had the Leopard disk handy and wanted to get things moving. My original machine had been upgraded as well so I didn't think anything of it. I then installed and started working with all my various programs.

    Well now I am having a terrible problem with the computer freezing up. I get the spinning color wheel often, with the computer freezing completely (no curser or keyboard response either) nearly as often. The color wheel happens once every 8-10 minutes, and the complete lock up happens around every 20 min and last for a solid 50 seconds.

    I tried reformating the drive and restoring from a backup of time machine (now I'm backing regularly), but it persists.
    I'd format and reload everything again, but that's a very heavy process, and I have too many old files replaced to do this easily, and I'm not sure how to do partials quickly and efficiently off of time machine.

    I need this station for work and can't afford to upgrade it. The machine worked very well previously before the glitch.

    Any help with a fix to the problem?
    If this is a no go, any advice on cleaning/fixing, then replacing backups quickly and efficiently without importing the problem if it's a software issue?

    Thanks.
     
  2. macthefork macrumors 6502

    Joined:
    Feb 2, 2013
    #2
    Check your Console Log to see if there is a process hanging and causing the slowdowns and freezes. Console is located in your Utilities Folder. (which is located in the Applications Folder)

    You can also check Activity Monitor to see what is taking processor usage. And, check memory usage here also. Does it show page outs? How much memory do you have installed?
     
  3. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #3
    I would do a hardware test on the iMac. It could be the cable connecting the drive to the Logic Board as I have seen that cause these issues. Another possibility is the RAM. Otherwise it just may be a corrupted install!
     
  4. williah thread starter macrumors newbie

    Joined:
    Jan 9, 2014
    #4
    Thanks, Macthefork, it seems you're right. I opened Console as recommended and saw these notes, which coincide with the freezes I was having while searching:

    Jan 11 14:36:14 william-brooks-imac kextd[643]: updated kernel boot caches
    Jan 11 14:36:14 william-brooks-imac com.apple.kextcache[11430]: Lock acquired; proceeding.
    Jan 11 14:36:14 william-brooks-imac com.apple.kextcache[11430]: /: no supported helper partitions to update.
    Jan 11 14:36:14 william-brooks-imac kextd[643]: updated kernel boot caches
    Jan 11 14:37:01 william-brooks-imac WebProcess[613]: INSERT-HANG-DETECTED: Tx time:31.734294, # of Inserts: 3, # of bytes written: 1436873, Did shrink: NO
    Jan 11 14:39:15 william-brooks-imac WebProcess[613]: INSERT-HANG-DETECTED: Tx time:30.243268, # of Inserts: 0, # of bytes written: 0, Did shrink: NO
    Jan 11 14:40:43 william-brooks-imac WebProcess[613]: INSERT-HANG-DETECTED: Tx time:28.526068, # of Inserts: 0, # of bytes written: 0, Did shrink: NO
    Jan 11 14:41:48 william-brooks-imac WebProcess[613]: INSERT-HANG-DETECTED: Tx time:28.661031, # of Inserts: 1, # of bytes written: 793, Did shrink: NO
    Jan 11 14:43:34 william-brooks-imac WebProcess[613]: INSERT-HANG-DETECTED: Tx time:4.386179, # of Inserts: 0, # of bytes written: 0, Did shrink: YES
    Jan 11 14:43:56 william-brooks-imac installd[758]: Exiting.


    I did some searches for the Insert-hange-detected note and found references to the same error. Unfortunately the only solution I found was to use Performance Update 1.0, which I tried and which didn't work.

    Anyone have any advice or experience with this?

    ----------

    Thanks, Altemose, I tried the hardware tests and didn't find anything. I did find the error above (prev post).
     
  5. macthefork macrumors 6502

    Joined:
    Feb 2, 2013
    #5
    Never mind... I just read you tried the Performance Update.

    Try resetting the PMU. This should be done after installing the Performance Update:

    Shut down the computer.
    Unplug the computer's power cord.
    Wait fifteen seconds.
    Attach the computer's power cord.
    Wait five seconds, then press the power button to turn on the computer.

    For many this has helped with that INSERT-HANG-DETECTED problem.
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    When you updated to 10.6.8, did your Safari also update?
    You SHOULD have Safari 5.1.10, if you are fully up-to-date...
    Recently, I have read about folks that reinstall 10.6, but Safari for some reason doesn't show to do that 5.1.10 update. You can download and install that manually from here: http://support.apple.com/kb/DL1569
    I don't know for sure that will help, but you are showing errors with WebProcess, which (I think) is part of WebKit, the code engine that Safari uses.

    After that, download and install the 10.6.8 combined updater: http://support.apple.com/kb/DL1399

    And after all that, if you have no improvement - You may have a temperature issue, so run some app that will allow you to check the sensor temps in your iMac, such as iStat Menu: http://download.cnet.com/iStat-Menus/3000-2086_4-10786476.html?tag=mncol;2
    Along with that, check that the small round cooling vent on the back, above your power cord, is completely clear.
     
  7. williah thread starter macrumors newbie

    Joined:
    Jan 9, 2014
    #7
    OK, here's my full update.

    Thank you, Deltamac, for the recommendations. I went thru each update but none worked. My SL and Safari were the latest versions available. I did decide to try to update each again anyway, to see if it triggered something, and when that failed I removed it and reinstalled it. Still no use.

    All this time I did have Console up and noticed that it only occurred while Safari was open.

    I then stopped opening Safari and switched to Chrome, and it hasn't stalled since (verified by Console).

    My solution, don't open Safari again. I would remove it, but I'm going to still look for a solution, as a matter of interest.
    The one thing that's driving me nuts in considering this is, why didn't it happen before my HD crashed? Is there a glitch in the installation process, or is the new HD (hardware) reacting and causing the glitch? I know the OS is 2 versions old, but I want to know.

    Thanks for all your help.
     

Share This Page