Spinning wheel when saving textedit file

Discussion in 'macOS' started by boba.slave, Jun 20, 2008.

  1. boba.slave macrumors newbie

    Joined:
    Jun 20, 2008
    #1
    Hello

    I'm using an iMac 20" 2.4GHz, 2GB Ram and Mac OS X 10.5.3.
    Since today I'm having the following problem:

    When I want to save a file with Textedit, I'm asked to give the file a name and when I click Save all I get is a spinning wheel. I have to do a 'force quit' of the textedit-application.

    When I make a file in the scripteditor I can save this file without problems in my documents folder.

    I've already tried to clear the caches but that doens't help.

    Can someone please help me? I'm new to Apple...
     
  2. G-Com macrumors regular

    Joined:
    May 21, 2008
    Location:
    North of The 'Nati
    #2
    Welcome to the brotherhood. :)

    Go to Applications>>Utilities>Disk Utility. Highlight your drive in the left panel and repair the disk permissions.

    If that doesn't work, do it in the OS X safe mode. Yes, it has one of them.

    1. Shut down completely
    2. Press the power button
    3. Wait for the startup chime
    4. Immediately after (not before) the startup chime, press and hold the shift key. Do this until the grey apple loading screen shows up.
    5. Wait while safe mode boots up. It will take a lot longer than regular OS X.
    6. Log in (press shift-enter instead of enter after putting in your password to log in without login items.)

    Then run the disk permission repair. This is also useful for removing software that's messing up your system.
     
  3. boba.slave thread starter macrumors newbie

    Joined:
    Jun 20, 2008
    #3
    Hello G-Com.

    Thanks G-Com for the tips.
    The system has repaired some settings regarding Airport.

    But the problem with my TextEdit wasn't solved. By coincidence I clicked at the Printers and Faxes (? I'm using the Dutch version of Os X) under Systempreferences and got the same spinning wheel. I was able to open all other items...
    A week ago I've been playing with CUPS (read in the book Foundations of Mac OS X Leopard security). A few days later I couldn't open the page 127.0.0.1:631.
    After investing the logs I saw some errors about org.cups.cups-lpd.plist and org.cups.cupsd.plist. The system was trying to start those files (?).
    I crossed my fingers and deleted those two files and restarted the system.

    And... now the TextEdit works, I can save docs, and I can open my Printers and faxes window.

    Does this make any sense?
     
  4. G-Com macrumors regular

    Joined:
    May 21, 2008
    Location:
    North of The 'Nati
    #4
    You're welcome :)

    I'd frankly never heard of that kind of file. I Googled that org.cups.cups-lpd.plist. Interesting. I don't have a working printer, but I'm going to get a new one soon.

    Repairing permissions has always fixed stuff for me.
     

Share This Page