Sporadic Magsafe Charger...

Discussion in 'Mac Basics and Help' started by numbertwelve, Apr 28, 2009.

  1. numbertwelve macrumors newbie

    Joined:
    Apr 28, 2009
    #1
    Hi everyone,

    My blackbook is about 6 months old now, and I've had occasional problems with the magsafe connector since then. Basically, it works most of the time, but sometimes when I plug it in, the light doesn't come on and the battery doesn't charge. I've tried using the connector to power up the computer without the battery, but that doesn't work either. It therefore seems to me like it could be a problem with the adaptor rather than the MB?

    As I say, I've had the problem a while now - this has happened on three seperate occasions, though eventually after a lot of taking the adaptor out and plugging it back in again (scientific, I know! :D) it inexpicably starts working again! It can sometimes be days before it works again though. But each time it starts working again I'm so relieved the problem seems to have gone away that I just forget about getting it sorted for the long term.

    Has anyone else had a similar problem? Is it definitely an adaptor problem? Should I just give up on the adaptor and go get a genius appointment?
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Have you...

    -tried it with another Macbook?
    -tried it with another battery?
    -what is the battery's charge when this happens?
     
  3. numbertwelve thread starter macrumors newbie

    Joined:
    Apr 28, 2009
    #3
    Hey, 'fraid I don't have immediate access to another Macbook or battery, but will try and steal a friends when I can :D .

    As for your final question, I have noticed that the battery charge is usually quite low (ie 'in the red') when I can't get the adaptor to work.
     
  4. allmIne macrumors 6502a

    allmIne

    Joined:
    Sep 17, 2008
    Location:
    United Kingdom
    #5
    Next time you plug it in and it doesn't charge, pull out the cable and check the pins. One of them is likely stuck 'in', so it's not connecting with the computer.

    I'm on my third magsafe cable for this very reason.
     

Share This Page