Spore Patch Problem

Discussion in 'Mac and PC Games' started by 0makol16, Dec 24, 2008.

  1. 0makol16 macrumors regular

    0makol16

    Joined:
    Oct 16, 2008
    Location:
    Diamond Bar, California
    #1
    Hi, I just got Spore and every time I start it up it says there is a new patch and when it is finally done it says to re-install Spore. So I did and it still wants to download the patch and re-install the game. Anyone know what to do? I know EA customer service won't help, they never really help.
     
  2. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #2
    Did you at least try them? Did you try the official Spore forum where end-users have found an effective solution?
     
  3. 0makol16 thread starter macrumors regular

    0makol16

    Joined:
    Oct 16, 2008
    Location:
    Diamond Bar, California
    #3
    YEs, I did call EA and got no help, they told me to do what I already did. And I checked the forums, people there are no help. Also I'm experiencing audio problems, there is no audio (yes I did try to unmute).
     
  4. gavriels macrumors newbie

    Joined:
    Sep 6, 2007
    #4
    There are three patches out for Spore. They have to be installed individually, so if you're starting from the disk, you'll see three 'There's a patch available' messages in a row, followed by a patch each time.

    I would delete the game, reinstall it from the disk, then just click 'OK' through the various patches. Note that the patches take a long time to run (about as long as the initial install), and that the first patch does not provide a great progress indicator; during patching of some of the big files it will just sit there for a long time. Don't force quit it half way through! That will lead to the audio issue you're describing, since the audio file is the big one that takes a long time to patch.
     

Share This Page