Spotlight always indexing

Discussion in 'OS X Yosemite (10.10)' started by Big Ron, Nov 16, 2014.

  1. Big Ron macrumors 6502

    Big Ron

    Joined:
    Dec 7, 2012
    Location:
    United Kingdom
    #1
    Does anyone know of a fool proof way to stop Spotlight automatically indexing my external drive DESPITE me adding into the private/ignore list?

    No matter how many times I instruct Spotlight to ignore my external drive - once I connect it it will start to index it. If I add the drive to the private/ignore list once connected Spotlight stops indexing but as soon as I connect it up again off Spotlight goes attempting to index it.:confused:

    Help:mad::mad:

    Im using Yosemite 10.10, but it did it to me using Mavericks
     
  2. ssls6 macrumors 6502a

    ssls6

    Joined:
    Feb 7, 2013
    #2
    you can add a root level file to stop spotlight

    sudo touch .metadata_never_index
     
  3. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #3
    Is this command for all drives or just - as OP asked - for his external drive?
     
  4. ssls6 macrumors 6502a

    ssls6

    Joined:
    Feb 7, 2013
    #4
    Just the drive you want indexing stopped on
     
  5. Big Ron thread starter macrumors 6502

    Big Ron

    Joined:
    Dec 7, 2012
    Location:
    United Kingdom
    #5
    Excellent thanks ssls6.

    I'm not however a "command line ninja" therefore:

    If Iopen up a terminal prompt and type this in - how does my Imac know to stop indexing on the external drive but continue indexing on my internal drive:rolleyes:

    Thanks
     
  6. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #6

    That's what puzzles me too!
     
  7. Bruno09, Nov 17, 2014
    Last edited: Nov 17, 2014

    Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #7
    Good question, indeed ;)

    The right command is :

    Code:
    sudo touch /Volumes/Name_of_volume/.metadata_never_index
    Replace Name_of_volume with the actual name of the volume you want to exclude from Spothlight.

    Example : if name of the volume = Clone

    Code:
    sudo touch /Volumes/Clone/.metadata_never_index
    
    If the name of the volume has a space in it, as "My Clone", you must replace the space with \ plus a space.

    Code:
    sudo touch /Volumes/My\ Clone/.metadata_never_index
    
    How to revert :

    Code:
    sudo rm -f /Volumes/Name_of_volume/.metadata_never_index
    
    You need to be in an admin account to use the "sudo" command.
     
  8. m4v3r1ck, Nov 17, 2014
    Last edited: Nov 17, 2014

    m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #8
    Spotlight always indexing


    Great answer to a good question! Thanks for your simple explenation for terminal noobs like me! ;)

    Cheers
     
  9. Big Ron thread starter macrumors 6502

    Big Ron

    Joined:
    Dec 7, 2012
    Location:
    United Kingdom
  10. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #10
    Another thank you to Bruno for a very useful post.

    I particularly liked the way you provided "guided examples" of how to use the Terminal commands...

    One more question:
    Do you know the proper terminal command to completely disable virtual memory in Yosemite?
     
  11. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #11
    Thank you.
    I am not a Terminal guy, though.

    To disable virtual memory, you might take a look at this.

    This is 2 years old, however on Yosemite, as far as I can see, the "com.apple.dynamic_pager.plist" file is in the same place and looks the same as on Mountain Lion and Mavericks.

    But take it with a grain of salt as I can't confirm that it works on Yosemite.
    I simply don't know and have not tested.
     
  12. spiderpumpkin macrumors member

    Joined:
    Oct 27, 2014
    #12
    Spotlight always indexing

    The first thing I do is uncheck everything in Spotlight setting. I Never use it anyways.
     

Share This Page