Spotlight and Finder search not working

Discussion in 'Mac OS X Lion (10.7)' started by macmaster24, Jul 21, 2011.

  1. macmaster24 macrumors member

    Joined:
    Feb 7, 2011
    Location:
    philly, PA
    #1
    I just upgraded my MBP from SL to Lion and everything is working fine exept that every time I search something in spotlight, it loads and only shows the dictionary entry, and when i hit the show in finder button, finder doesn't even display anything. I tried re-indexing, but i don't think it worked, because there was no progress bar or anything. i think the protocols of lion are different. i no my way around a mac soo if anyone has any suggestions, they would be greatly appreciated :D

    I<3:apple:
     
  2. macmaster24 thread starter macrumors member

    Joined:
    Feb 7, 2011
    Location:
    philly, PA
  3. MacLover2 macrumors newbie

    Joined:
    May 22, 2009
    #3
    Weird Spotlight stuff

    I on a Mac Pro and having the same issues
    Spotlight doesn't accurately tell you if it is indexing or not
    Definitely doesn't have the coverage of email etc
    Search for a term yesterday and some emails cam up the searched for the same term today and nothing there!!!

    What is happening to Spotlight ????
     
  4. drunifex macrumors member

    Joined:
    Nov 18, 2008
    #4
    Ditto


    Search brings up the dictionary only
     
  5. rharder macrumors newbie

    Joined:
    Jun 21, 2002
    #5
    Similar: MacBook Pro, Lion, Dictionary and Web searches only:

    [​IMG]

    -Rob
     
  6. arkoh macrumors member

    Joined:
    May 24, 2009
    Location:
    Copenhagen
    #6
    Ohhh boy... I'm happy to see that I am not the only one with this issue! That makes it plausible that I might find a solution... ;-)

    Anyone having found a solution by now!?? Please!??? :eek:
     
  7. kevin2i macrumors member

    Joined:
    Apr 25, 2011
    #7
    Have you checked spotlight preferences and privacy settings?

    My spotlight works fine (still using the GM) - but I don't like the 'improvement' either.
     
  8. spudwaffle macrumors newbie

    Joined:
    Oct 20, 2010
    #8
    Make sure everything is checked (from Spotlight in System Preferences)
    [​IMG]
    and make sure nothing big (e.g. your whole hard disk) is added here
    [​IMG]

    If that all checks out, force spotlight to reindex.
    Add your whole hard drive to the above privacy list.
    Then quit System Preferences, relaunch it, and remove everything from the same list.

    Spotlight should start indexing. This may take a very long time.
     
  9. arkoh macrumors member

    Joined:
    May 24, 2009
    Location:
    Copenhagen
    #9

    Everything is on... tried it all, several times... nothing helps!!?? I cannot add the c-drive to the "privacy list", it just says something like "Error... subject couldn't be added or removed due to an unknown error"! Really helpful information!!!

    I've had the indexing starting over... nothing helps! I'm almost at the point, where I'll have to reinstall Lion on a clean hard drive!

    Anyone having dealt with this issue that has actually solved it!?
     
  10. Vicros macrumors newbie

    Joined:
    Nov 19, 2009
    #10
    I've been working on getting this resolved for over a week. So far I've done a clean install, re-indexed at least a dozen times, and every other suggestion given on various forums. Nothing has worked. Well I take that back, the clean install did work. It worked until I restarted my machine. After a restart, the problem re-surfaced.

    I took my machine to the Genius Bar and the Genius was stuck. He tooled around for about an hour and all he could say was "I'm stumped".

    I'm now working with Apple Support via phone. They sent me a file to run some sort of log on my system which I did and returned. My rep told me that he has forwarded it along to an engineer. Right now I'm in a holding pattern.
     
  11. arkoh macrumors member

    Joined:
    May 24, 2009
    Location:
    Copenhagen
    #11

    @Vicros

    Please, keep me informed of how things go! I have given up here... and unfortunately, in Denmark we've got no Genius bar to take the thing to! ;-)

    Well... I could do the big reinstall, but got to many programs and stuff installed, for this to be a simple task! :-/

    Would be greatly appreciated!
     
  12. arkoh macrumors member

    Joined:
    May 24, 2009
    Location:
    Copenhagen
    #12
    Hmmmm... things just keeps getting more and more strange here...!!??

    By coincident, I found out that all of a sudden I now have a working spotlight!? BUT... it is only because my indexing is working hard to try to index the hard drive AGAIN!!! So when it is working to index... spotlight is working! When it is done indexing... spotlight is "out of order" again!!!???

    What in heavens name is going on!??? :mad:
     
  13. Vicros macrumors newbie

    Joined:
    Nov 19, 2009
    #13
    10.7.1 did not fix my issue wit Spotlight or Finder search. I've sent a follow-up email to my support contact, we'll see what he says.

    If I can't get this resolved soon, I very well may return my Mini Server and try my luck with a different unit.
     
  14. mhrob macrumors newbie

    Joined:
    May 17, 2004
    #14
    Certain characters seem to not register...

    Certain characters also seem to not register... For example, I am searching for a folder that begins with a "$" sign... Spotlight gives no items found, but I see two folders beginning with a "$" in my Documents folder. Plain as day, there are two folder named with that sign ($$$ In, $$$ Out). Bills and invoices. I have a copy of these folders on a shared computer, same thing.

    If I search my shared PPC computer from within itself, the Leopard spotlight finds over 10,000 items containing the "$" sign.

    A very serious problem, if you ask me. What other characters are not kosher, I wonder...
     
  15. rizkallam macrumors newbie

    Joined:
    Sep 30, 2011
  16. MacMySongs macrumors newbie

    Joined:
    Mar 3, 2008
    #16
    Same weird Spotlight problem!

    This is INSANE! I worked w/ AppleCare and they had me reindex Spotlight, change the Privacy settings, etc. Same as everyone else.

    It worked for about a day. Now? If I click "Show all in finder" it comes up blank. Nothing.

    This is how I used to feel when I was in the Windows world.

    Come on, Apple, fix this!
     
  17. midnite26 macrumors newbie

    Joined:
    Jun 9, 2009
    #17
    Same here

    Same problem here...

    Will keep an eye on this forum.
     
  18. MacInMotion macrumors newbie

    Joined:
    Feb 24, 2008
    #18
    Maybe?

    I found a couple of possible answers at StackExchange. Crashing plug-in seems to fit your symptoms.

    Let us know what you find.
     
  19. CraigH macrumors newbie

    Joined:
    Oct 28, 2011
    #19
    "show all" doesn't work

    It worked for about a day. Now? If I click "Show all in finder" it comes up blank. Nothing.


    I have the same problem except it appears to be searching - at least the little activity wheel is turning.
     
  20. jbrehm macrumors newbie

    Joined:
    Nov 7, 2011
    #20
    Spotlight working, finder isn't

    I'm having the same problem since upgrading to Lion. I have a mac pro. Spotlight seems to be finding files correctly, but when I "Show all in finder" I get an empty finder window. Searching in finder does nothing. This actually seemed to start after I was trying to create a smart folder. The smart folder was working correctly for about 10 minutes, then finder searches stopped working all together.
     
  21. Paulinderwick macrumors newbie

    Joined:
    Nov 8, 2011
    #21
    Spotlight problems

    Recently bought a new MacBookPro - originally SL but then upgraded to Lion. However apart from the idiocy of restarting unwanted programs spotlight will now only return Office documents! Has Gates found a way to take over Apple on some sort of compulsory basis? I have hundreds and hundreds of Keynote presentations which I need to search using Spotlight but it will only return search results in Word or Powerpoint documents. Am I, or is my MacBook Pro, going mad??
     
  22. mantelvaviz macrumors newbie

    Joined:
    Nov 16, 2011
    #22
  23. spitboy2000 macrumors member

    Joined:
    Nov 2, 2007
    #23
    My spotlight and finder search couldn't find an elephant in a closet

    I get blank results for everything

    someone please help
     
  24. mantelvaviz macrumors newbie

    Joined:
    Nov 16, 2011
    #24
  25. eternalife macrumors regular

    Joined:
    Jul 21, 2011
    #25
    Download Alfred and use it instead. It's the best search/launcher/everything out there.
     

Share This Page