Spotlight calculator broken, because of 10.5.2

Discussion in 'macOS' started by big_malk, Feb 14, 2008.

  1. big_malk macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #1
    My Calculator in Spotlight doesn't work anymore... I think its batteries might be dead? When I type in things like "4+4" the search works fine, but it doesn't give any math results. I think it stopped around the time I installed 10.5.2 but it may have been broken before that, I can't remember exactly.

    I'v tried this this but it didn't help, not sure what else to try?

    Thanks
     
  2. RumMunkey macrumors 6502a

    RumMunkey

    Joined:
    Nov 3, 2006
    Location:
    Canada
    #2
    Working here

    [​IMG]

    Leopard 10.5.2 on a PowerBook G4. Don't know what to tell ya.

    Can you maybe edit your thread title to something like "Spotlight calculator not working. 10.5.2 related?" since we're not sure, and by the title it looks like a confirmed bug.
     
  3. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #3
    Also working for me on Intel Macs running 10.5.2.

    There's gotta be something else going on with the OP's computer. This blame-every-little-problem-on-10.5.2 is starting to get old.
     
  4. JSchwage macrumors 6502a

    JSchwage

    Joined:
    May 5, 2006
    Location:
    Rochester, NY
    #4
    Working perfectly for me. Maybe try installing the 10.5.2 combo update and see if that fixes it. Also, try repairing permissions before you install the combo update.
     
  5. big_malk thread starter macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #5
    I haven't tried to blame every problem on 10.5.2, but generally when something goes wrong, something has caused it. And when asking for help, giving as much information as possible about what might have caused it helps quit a bit.
     
  6. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #6

    And we've established that others using 10.5.2 can't reproduce the problem. So now, we must figure out what else might be the cause.


    There doesn't seem to be anything in spotlight preferences that specifically disables evaluation of math expressions, but have you checked there to see if anything is unchecked? Maybe play around with the settings... perhaps unchecking everything, and see if there's a change.

    You could also try wiping the spotlight index clean and having it start over, by going into Terminal and entering:

    Code:
    sudo mdutil -E /
    You could also try deleting ./Library/Preferences/com.apple.spotlight.plist if it's there, restart, and run the above command again.
     
  7. big_malk thread starter macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #7
    @ scaredpoet Thanks for your help, but I've tried all you said and still no luck :(
     
  8. DocRoss macrumors newbie

    Joined:
    Sep 3, 2004
    #8
    I am having the same trouble. It, too, started with updating to 10.5.2. It worked before, it doesn't now.

    I have tried forcing Spotlight to create a new index, I have used the Terminal to turn calculation on and off (per MacOSXHints), and I have had no luck.

    If I find a solution somewhere, I'll post it here.
     
  9. big_malk thread starter macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #9
    My calculator has started working again, and I don't even know what fixed it. I did everything Scaredpoet said, it didn't fix it right away, but I can't think of anything else that cause have fixed it. Try all that and restart a few times.
     
  10. youknowho macrumors newbie

    Joined:
    Feb 22, 2008
    #10
    My spotlight calculator stopped working IMMEDIATELY after "upgrading" to Leopard 10.5.2 with no other system changes (MacBook Pro). I tried the terminal commands to set the calculator and restart it. Still nothing. Definitely this update's fault and hopefully mine will mysteriously start working again like the OP's.

    Honestly this feels a lot like a Windows quirk (using that OS for years now so I should know) and is exactly the kind of thing I tried to avoid by using a Mac. An update breaks something and I have to hunt down some esoteric command line fix that still doesn't solve the problem.

    I LOVED Tiger. Leopard broke lots of what I loved about it (Terminal exporting shortcuts to connections - GONE, Terminal dragging highlighted text to command line (with my Kensington mouse) - GONE, "It just works" - GONE).

    That "downgrade" to Tiger is looking more and more appealing.
     
  11. Xavier macrumors 68020

    Joined:
    Mar 23, 2006
    Location:
    Columbus
    #11
    Wow i never knew you could do that! Pretty cool

    It works for me though, dunno what the problem is
     
  12. GeorgeL910 macrumors newbie

    Joined:
    Feb 25, 2008
    #12
    Same Problem

    I'm using a PowerBook G4 (1.67 GHz processor, 1.5 GB RAM) and have the same issue with Spotlight. I do get "Definitions" when I enter a word into Spotlight, but the calculator feature does not work. I have tried all the "fixes" mentioned to date.
     
  13. unregbaron macrumors regular

    Joined:
    Oct 20, 2002
    #13

    I'm in the same position...
     
  14. GeorgeL910 macrumors newbie

    Joined:
    Feb 25, 2008
    #14
    Found A Solution

    As indicated in an earlier posting I had been unable to get the "Spotlight calculator" to work either. In looking in Spotlight Preferences I noticed that Applications need to be checked for Spotlight to search there, and made an assumption that maybe Spotlight calculator was using the "Calculator" program found in applications. Since I had moved my "Calculator" program onto the Desktop Dock it wasn't appearing in any of the items in Preferences that could be checked. Once I moved "Calculator" off Desktop Dock and back into the "Applications" folder, my Spotlight Calculator appeared as advertised! I think everyone needs to be sure the Calculator program is in a folder being checked by Spotlight, in order for this function to work.
     
  15. sbstrum macrumors newbie

    Joined:
    Mar 25, 2008
    #15
    Solution to Calculator Not Working in Spotlight

    I am a relatively new MacBookPro user that found the calculator in Spotlight not to function. I spent hours reading various posts. I finally called AppleCare and promptly obtained a solution:
    1. My app for Calculator was missing; somehow it was trashed and deleted.
    2. I used a freeware program called Pacifist to extract Calculator.app from my Mac OS X install discs. Calculator.app was extracted to be sent to Applications.
    3. Rebooted and Spotlight calculator works.

    I think this might be helpful approach for those who might have either deleted or corrupted the Calculator.app which is the way Spotlight functions to perform calculations.

    Hopefully, this will save someone hours of searching for a solution.
    SBS
     
  16. Globetrotter macrumors regular

    Globetrotter

    Joined:
    Nov 5, 2007
    Location:
    London
    #16
    It is the missing app which gives one pause for concern ! :eek:
     
  17. GanjaManja macrumors newbie

    Joined:
    Mar 15, 2007
    #17
    Mine broke, not just from 10.5.2

    (btw, I love the dictionary & calculator in Spotlight, it's much faster and less resource-hungry than QuickSilver, as amazing as QS is. As an engineer, i use it all the time, it's functionality is invaluable! Google's built-in calc is a close second)
    [OS X 10.5.2, Mac Mini Intel. Just happened today, while 10.5.2 was auto-installed a while ago, probably a few weeks.]

    I recently plugged in a new USB harddrive, which is formatted as windows FAT32, and has a friend's entire C:/ windoze drive backed up on it.

    A while later, spotlight was indexing the drive, preventing me from using the search.
    Then spotlight was fine.
    Then spotlight was indexing MY drive.
    Then spotlight was fine.

    There's some funny console errors, the most interesting of which are these:
    5/20/08 4:39:03 PM mds[35] (/.Spotlight-V100/Store-V1/Stores/42E73FCC-D1CA-41E1-B653-11B47F0B749B)(Error) IndexGeneral in notify_lowspace:low space for device 234881026 (/.Spotlight-V100/Store-V1/Stores/42E73FCC-D1CA-41E1-B653-11B47F0B749B)
    5/20/08 4:39:03 PM mds[35] (Error) Volume: LOW DISK SPACE device:234881026
    5/20/08 4:39:03 PM mds[35] ((null))(Error) IndexCI in bt_openTrie:eek:pen live.115.indexDirectory err: 24
    5/20/08 4:39:03 PM mds[35] (/.Spotlight-V100/Store-V1/Stores/42E73FCC-D1CA-41E1-B653-11B47F0B749B)(Error) IndexCI in openPayload:eek:pen err: 2, live.0.shadowIndexTermIds


    but my root drive has 2.28 GB free, all the rest have more than 1 Gig free...
    also some errors show inability to load some sourcecode module, but i think i've seen that in the logs for a while without loss of functionality, (maybe since 10.5.2?).

    spotlight intermittently indexes something on my root drive (dot shows in the menu icon & can't use the search), i have no idea why, but ever since this monkey business, my calculator has gone kaput. The dictionary works, the search works mostly, but isn't picking up newer files...
    (my Applications/Calculator.app is working perfectly fine, never moved it or had any problems)

    trying defaults write com.apple.spotlight CalculationEnabled YES returns this:
    5/20/08 5:06:35 PM defaults[1967]
    The domain/default pair of (com.apple.spotlight, CalculationEnabled) does not exist

    and
    defaults read com.apple.spotlight doesn't list dictionary or calculator options. I can print that here if anyone so desires.

    bizarro spotlight.
    so the database must be corrupt.
    sudo mdutil -E / returns this:
    Password:
    /:
    Indexing disabled.

    even after sudo mdutil -i on -v -E / and every combination of -i ON, -E etc. i can think of.


    Spotlight's being a jerk! I'm not sure how to recover/reset the database!
    The SysPrefs pane looks normal.

    Anybody got more ideas?
     
  18. GanjaManja macrumors newbie

    Joined:
    Mar 15, 2007
    #18
    I fixed it

    So it turns out I was using the mdutil incorrectly.

    It seems that, similar to what GeorgeL910 guessed above, you can't do calculations in your SpotLight if Calculator.app isn't in it's index.
    It turns out that somehow (i really don't know why), my root drive and another hard drive suddenly had indexing disabled. (I noticed this by typing sudo mdutil -s -a , which is "status" of "all drives")

    Previously, I was doing mdutil -E / and recieving the /: indexing disabled message. Trying to enable it with mdutil -i ON didn't work, and didn't return any errors (or console messages) so i didn't know what was up. Apparently you must type a drive name after the aforementioned command!

    I fixed everything by, in Applications/Utilities/Terminal.app, typing:
    sudo mdutil -i ON -a (turn indexing ON on all drives)
    sudo mdutil -E -a (Erase+rebuild database on all drives)

    hey presto, everything's fixed! why indexing got turned off (and database possible corrupted) when i plugged in my new external USB HD, I may never know...
     
  19. mgalle macrumors newbie

    Joined:
    Jun 18, 2008
    #19
    It seems I've the same problem. I used the calculator function on spotlight a lot, until I updated to 10.5.2, when it stopped working. Updating to 10.5.3 didn't fix the problem.

    I tried the different solutions posted here, but I didn't advance. Dictionary works well, and the most strange is that the calculator function *does* work for other user then the administrator one I use normally. I copied the Library/Preferences/com.apple.spotlight.plist from the user where I haven't the problem, without solution.

    Any other user who fixed this problem in a different way?

    I'm using a MacBook Pro (nov 2007).
     
  20. GanjaManja macrumors newbie

    Joined:
    Mar 15, 2007
    #20
    What does the command
    sudo mdutil -s -a (for all drives)
    or
    sudo mdutil -s / (for just your OS drive)
    return?

    Also, what does
    ls -fl /Applications | grep calculator
    return? (check that you have permissions to use Calculator)

    if
    sudo mdutil -s /
    returns "Indexing Enabled", then try
    sudo mdutil -E /



     
  21. mgalle macrumors newbie

    Joined:
    Jun 18, 2008
    #21
    Thanks a lot for your answer

    "Indexing enable" for all drives.

    $ ls -lf /Applications/ | grep Calculator
    drwxrwxr-x 3 root admin 102 12 Oct 2007 Calculator.app


    No result...
     
  22. brucku macrumors regular

    Joined:
    Jun 19, 2003
    #22
    Just fixed

    Just fixed this by opening calculator and closing it.
     
  23. Nym macrumors 6502a

    Nym

    Joined:
    Oct 4, 2006
    Location:
    Porto, Portugal
    #23
    I did exactly the same as the you and it worked as well!

    I'm laughing my ass off just by looking at all the posts above (a lot of Terminal tinkering) when all I did to fix this was restart the application! :D

    Anyway, thanks for the fix! This was bugging me since I reinstalled Leopard 2 weeks ago! Now it's gone!
     
  24. GanjaManja macrumors newbie

    Joined:
    Mar 15, 2007
    #24
    Wow, i wish it had been that simple for me! I will say that when i had this problem it was a symptom of corrupt/broken Spotlight databasing/internal organs.
     
  25. nomisj macrumors newbie

    Joined:
    Jul 20, 2008
    #25
    i still cant get it to work after restarting, quitting the app, anyone have a solution for sure?
     

Share This Page