Spotlight 'developer' and 'Web searches' can't be disabled?

retro83

macrumors member
Original poster
Feb 3, 2008
57
0
Got these two sections showing in spotlight that I don't want (I only use it for apps). Any ideas how to disable them?

Developer (which appears to be any HTML, JAR, NFO etc) and web search.



Can't find any option for them in the settings pane. It's obviously not a major issue, just irritating that the majority of the results it shows are things i'm never going to want.



Cheers

Edit: The files shown come from all over the filesystem, not the 'developer' directory
 

andreas.b

macrumors newbie
Mar 14, 2005
24
0
Scratching my head over this as well. This stuff is cluttering up the search results.
 
Comment

retro83

macrumors member
Original poster
Feb 3, 2008
57
0
Thought this might have been there because I used to have developer tools installed - it isn't. Clean install, and still have the annoying results.
 
Comment

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,172
9,849
California
Thought this might have been there because I used to have developer tools installed - it isn't. Clean install, and still have the annoying results.
I thought the same thing and messed around a few minutes looking for an old Developer folder to delete.
 
Comment

bader308

macrumors newbie
Oct 25, 2007
2
0
Having the same problem, have been searching for days but no solution found yet.
 
Comment

gumblecosby

macrumors 6502
Jun 22, 2010
296
5
Just a suggestion. Maybe you could add a custom entry to the plist that handles Spotlight indexing to block all html.


For developer results, you could try adding the "System" and "Library" folders to the privacy tab in preferences if you havent already.
 
Comment

bader308

macrumors newbie
Oct 25, 2007
2
0
Just a suggestion. Maybe you could add a custom entry to the plist that handles Spotlight indexing to block all html.


For developer results, you could try adding the "System" and "Library" folders to the privacy tab in preferences if you havent already.
I suppose it can be done by plist editing, but can't figure out what string to use as a reference for DEVELOPER results.
 
Comment

BL4zD

macrumors 6502
Sep 22, 2010
273
6
I hope this is addressed in a patch because it doesn't make sense to have it on without the ability to turn it off.
 
Comment

little johnny

macrumors newbie
Nov 13, 2007
10
0
Just a suggestion. Maybe you could add a custom entry to the plist that handles Spotlight indexing to block all html.


For developer results, you could try adding the "System" and "Library" folders to the privacy tab in preferences if you havent already.
Privacy tab trick doesn't work. It might work if one enabled the setting, then wiped their spotlight index, and then reindexed. But after indexing (and not rebooting anyway), it doesn't work.

This is maximally annoying.
 
Comment

xizar

macrumors regular
Dec 17, 2009
112
0
My issue with Spotlight Finder is that *everything* is either a "Developer" document type or "Document" document type. There is not finer resolution (images are not "images", they're "documents", same with mp3s and applications.)

I called up Apple Support, got escalated up to someone who was also confused by this and had me run some kind of info harvester to upload files to him.

I'm still waiting to hear back.

Afterthought:
My iMac with XCode installed doesn't have this problem. Both Lion and XCode were installed directly from the App Store.
The macbook which does have this problem does not have XCode, and I installed Lion off of a DVD that I put the installer file I snuck out of the downloaded version I put on my iMac.
Both versions were upgrades, as opposed to clean installs.
 
Last edited:
Comment

Partron22

macrumors 68030
Apr 13, 2011
2,556
746
Yes
I tried adding a "Developer" entry to the dictionary in Spotlight's plist.
That does show up in the spotlight prefs pane, but it just gets me TWO copies of the Developer listing in Spotlight results.
-Not very useful.
I think it likely that some piece of software you've installed has a Spotlight dictionary entry in its plist.
The trick'll be to find it, and eliminate it.
 
Last edited:
Comment

retro83

macrumors member
Original poster
Feb 3, 2008
57
0
Maybe I misunderstand but I don't think it's caused by external software, i did a completely clean install of 10.7. With no other software installed, I still had the developer entries listed.

In my case these are mostly .log files from my music directory (rip history from EAC) and html files from various places on the filesystem.

(This was without installing the developer tools, BTW).
 
Comment

Partron22

macrumors 68030
Apr 13, 2011
2,556
746
Yes
I don't think it's caused by external software...
Yeah, it could easily be an oversight on something installed as part of Lion. The OS whole has a "rushed out the door" feel to it, and that's how errors like this slip through.
 
Comment

OliverJAsh

macrumors newbie
Jun 10, 2011
5
0
I've found a fix for removing the developer category.

  1. Go to ~/Library/Preferences/com.apple.spotlight.plist
  2. Open Terminal. You will need to convert the file to XML (from binary) so you can edit it in TextEdit. The command you need is plutil -convert xml1 ~/Library/Preferences/com.apple.spotlight.plist
  3. Open this file in TextEdit. Just before </array> at the bottom, add the following:
    Code:
    		<dict>
    			<key>enabled</key>
    			<false/>
    			<key>name</key>
    			<string>SOURCE</string>
    		</dict>
  4. Convert the file back to binary using plutil -convert binary1 ~/Library/Preferences/com.apple.spotlight.plist
  5. Log out and back in again.

That worked for me. Remember to backup the com.apple.spotlight.plist file beforehand! Just in case...

Oliver
 
Comment

retro83

macrumors member
Original poster
Feb 3, 2008
57
0
I've found a fix for removing the developer category.

  1. Go to ~/Library/Preferences/com.apple.spotlight.plist
  2. Open Terminal. You will need to convert the file to XML (from binary) so you can edit it in TextEdit. The command you need is plutil -convert xml1 ~/Library/Preferences/com.apple.spotlight.plist
  3. Open this file in TextEdit. Just before </array> at the bottom, add the following:
    Code:
    		<dict>
    			<key>enabled</key>
    			<false/>
    			<key>name</key>
    			<string>SOURCE</string>
    		</dict>
  4. Convert the file back to binary using plutil -convert binary1 ~/Library/Preferences/com.apple.spotlight.plist
  5. Log out and back in again.

That worked for me. Remember to backup the com.apple.spotlight.plist file beforehand! Just in case...

Oliver
Fantastic, thank you very much for that.
 
Comment

RedTomato

macrumors 601
Mar 4, 2005
4,033
328
.. London ..
I brought a newish Macbook Air a few months ago, and installed Yosemite on it from scratch - I didn't bring over any old files from my former macs, apart from what I can access through Dropbox.

Now my Spotlight results are cluttered up with all this Developer crap. I've never had Xcode on this mac.

I've tried the hack suggested above, but it didn't work at all. Still got this Developer stuff forming 90% of my Spotlight results.

How do I get rid of it?

Here's the last part of my Spotlight prefs:
Code:
                <dict>
			<key>enabled</key>
			<false/>
			<key>name</key>
			<string>MENU_WEBSEARCH</string>
		</dict>
		<dict>
			<key>enabled</key>
			<false/>
			<key>name</key>
			<string>SOURCE</string>
		</dict>
	</array>
	<key>showedFTE</key>
	<true/>
	<key>showedLearnMore</key>
	<true/>
	<key>useCount</key>
	<integer>3</integer>
	<key>version</key>
	<integer>7</integer>
</dict>
</plist>
 
Comment

0004838

Suspended
Oct 1, 2014
193
64
ditto Mavericks. I don't need three of the Spotlight categories at all: "Other", "Search Wikipedia" and "Search Web". There's a solution to removing the "Other" category, but I can't find one for the other two :(
 
Comment

cobra267

macrumors newbie
Sep 30, 2015
2
0
There is a solution to this on Yosemite. It is to create a dummy Xcode application in the applications folder, then Spotlight will think you are a dev and allow you to turn it developer search results off.

To create the dummy Xcode app you have to go in to terminal and paste these separately otherwise it'll not work...

Code:
cd /Applications
touch Xcode.app
Then go into system preferences and uncheck "Developer" form Spotlight searches. You may have to reopen system preferences to see the option appear...

Then open another terminal window and paste this to hide the dummy app, don't worry as spotlight will still think Xcode is installed

Code:
chflags hidden /Applications/Xcode.app
And there you are developer search results are hidden on Yosemite :apple:
 
Comment

hobspain

macrumors regular
Mar 29, 2010
110
78
There is a solution to this on Yosemite. It is to create a dummy Xcode application in the applications folder, then Spotlight will think you are a dev and allow you to turn it developer search results off.

To create the dummy Xcode app you have to go in to terminal and paste these separately otherwise it'll not work...

Code:
cd /Applications
touch Xcode.app
Then go into system preferences and uncheck "Developer" form Spotlight searches. You may have to reopen system preferences to see the option appear...

Then open another terminal window and paste this to hide the dummy app, don't worry as spotlight will still think Xcode is installed

Code:
chflags hidden /Applications/Xcode.app
And there you are developer search results are hidden on Yosemite :apple:
Didn't work for me on El Capitan 10.11 . Did you create it the dummy file with user privileges or root? What chmod did you assign?
 
Comment

cobra267

macrumors newbie
Sep 30, 2015
2
0
Comment

gristel

macrumors newbie
Feb 15, 2016
2
0
Belgium
For me, on El Capitan, the touch Xcode.app in /Applications worked fine. Afterwards I could uncheck the Developer box in System Preferences -> Spotlight.
I could also safely remove the dummy file again and the result remained unchanged.
 
Comment

Similar threads

Replies
4
Views
2K
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.