Spotlight Doesn't Search System Preferences SOLVED

Discussion in 'Mac OS X Lion (10.7)' started by wsanders, Feb 18, 2013.

  1. wsanders, Feb 18, 2013
    Last edited: Nov 25, 2013

    wsanders macrumors newbie

    Feb 21, 2011
    Since upgrading to Lion, Spotlight doesn't find any results in System Preferences. For example, i used to be able to type in "Sounds" or "Displays" and open them from Spotlight without having to open System Preferences. And, yes, I have "System Preferences" checked in the Spotlight options.

    Anyone else seen this? This is happening on both my Macbooks running Lion.


    SOLVED: Do not exclude /System and /Library from Spotlight. Unfortunately if you have Xcode installed Spotlight will search all your .h files and bring up a bunch of junk results under "Developer". There is no option to uncheck Developer in Spotlight Options. To fix, exclude /System/Library/Frameworks and /Library/Frameworks rather than all of /System and /Library and most of the junk results will go away.

    Weird it still can't find "Displays", but it finds "Energy Saver" instead.

Share This Page