Spotlight has no index

Discussion in 'macOS' started by Kenriver, Mar 16, 2009.

  1. Kenriver macrumors newbie

    Joined:
    Mar 16, 2009
    #1
    Hi. My Spotlight in OS 10.4.11 is broken and I’ve been looking at these forums for help. I have found several fixes, but unfortunately none have worked.

    I have gone to the “Private” tab under Spotlight preferences and dragged in my hard drive. The green “plus” sign lights up, but once I let go nothing ever gets added to the list. I’ve tried it with everything and nothing gets added.

    I’ve gone to Terminal and typed “sudo mdutil -E /” plus my password. It returns: “Error, no index found for volume.”

    I’ve tried “sudo open /.Spotlight-V100” and it says the folder cannot be opened because I do not have sufficient access privileges. Does anyone know where to find this folder on my hard drive so I can get to it manually? I am hoping it might ask for my password once I’m there. As the administrator, does anyone know how to make the OS know that I do have sufficient privileges?

    And I have repaired my permissions and that helps none of the above.

    The things I have not done are use disk repair because I do not have a boot disk. I have not reinstalled because the OS came on my computer and I have no disks. I would think re-installing would do the trick, but there has to be something else going on that can be tweeked, wouldn't you think?

    So, any other ideas before I have to spend $120? Thanks!

    Ken
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    It sounds to me as if the .Spotlight folder somehow ended up with permissions such that Spotlight isn't being able to read/modify it. What I'd try doing is deleting both the Spotlight prefs file and that folder.

    The preferences I think are here:
    /Users/YOUR_HOME_FOLDER/Library/Preferences/com.apple.spotlight.plist
    (or you can delete it from the terminal with "rm ~/Library/Preferences/com.apple.spotlight.plist" ... but I'd use the Finder.)

    To delete the root spotlight folder (we are talking about your boot drive that isn't being indexed, right?):
    Code:
    sudo rm -R /.Spotlight-V100
    You should then be asked for your admin password and it will remove the Spotlight folder and all its contents. Be darned sure you type it correctly (as in, no space between the / and the .), lest you do horrible things to your drive. In fact, back up anything really important first, just in case.

    In theory, at this point, you should be able to add the drive to the privacy list in Spotlight's pref pane, then remove it, and indexing should take place.

    Alternately, you could wait for someone who has a better guess to make a suggestion, or try what this thread suggests:
    http://discussions.apple.com/thread.jspa?messageID=4743585
    ...and see if that gets you in the right direction.

    Just for reference, you could also open up terminal and type "cd /" followed by a return, followed by "ls -al" and return, then copy and paste what you get back; this will tell you if that folder at least exists, and if it does what permissions it has.
     
  3. SamNeeds macrumors regular

    Joined:
    Dec 28, 2007

Share This Page