Spotlight - HHHEEELLLPPP!!! :(


macrumors newbie
Original poster
May 18, 2006
Hi everyone!

Spotlight has suddenly decided to DIE on me, and nothing I've tried will resurrect it!

Basically, I can still type what I'm looking for in the Spotlight search bar in my Finder menu, but no results are found. In fact, if I evoke a Find command using Apple+F and I type in (let's say) the name of a file, the search process goes on, and on, and on and never produces any results.

Here's what I tried so far:

1. I deleted my Spotlight index using every possible means I could think of, i.e. using the sudo mdutil -E / in Terminal, dragging my HD into and then out of Spotlight's Privacy preference pane, using Spotless 1.1, and even trashing the whole .Spotlight-V100 folder. Each time, Spotlight rebuilds its index, but I still get no results when I try and search.

2. I rebooted my computer after deleting my Spotlight index so as to have it rebuild on a clean restart. Once again, the index rebuilt, but Spotlight still doesn't find anything.

3. I repaired permissions and ran a Verify Disk using Disk Utility - no problems found, and Spotlight still doesn't work.

4. I booted into safe mode - this had no effect on the problem.

I have a MacBook Pro 15-inch computer running Mac OS 10.4.6 with all the updates available from Apple.

If anyone has any idea what might be going on with my Spotlight functionality, please let me know.

This is really, really weird!

Thanking you all in advance for any suggestions and/or advice you can offer.



mad jew

Moderator emeritus
Apr 3, 2004
Adelaide, Australia
Wow, that's a lot of different methods, nice work. :)

You deleted your index, but have you deleted your preference file (named and restarted? :)


macrumors 6502
Jul 31, 2004
Denton, TX
I guess if all else fails you could always start to use QuickSilver instead. I've heard thats actually a pretty cool little program.


macrumors newbie
Original poster
May 18, 2006
Spotlight - HHHEEELLLPPP!!! :( - Follow up & even stranger!

Hi everyone!

First of all, thank you for the suggestions I have received thus far. I really appreciate your help! :)

I forgot to mention that I did trash the file from my computer as one of the recourses I attempted and then rebooted my computer. Unfortunately, this did not resolve the problem.

Here's what's really weird, though... I gave up trying to fix spotlight at about 3AM this morning. I shut my computer down (as I had done at least a dozen times while trying to fix the problem) and called it a night. When I started my computer again at about 7AM, I decided to try Spotlight again, and the DA&NED thing worked perfectly! :mad:

While I'm happy it's now working, I have NO idea what caused the problem in the first place!

I sure hope it doesn't happen again, though! That was ONE STRANGE PROBLEM! :(

- Pietro


macrumors regular
May 1, 2006
I had the same problem. If I restarted SystemUIServer a few times then Spotlight worked just fine. If I trashed the index file and got Spotlight to reindex it would be fine but if I restarted it wouldn't work again until I once again re-indexed.

I tried EVERYTHING but in the end it was a re-install that fixed the issue. This reminded me of the Windows days of regular system reinstalls (Not a nice memory)

I really hope that OS X Leopard has "Spotlight 2.0" as the current version is quite buggy, Apple's discussion boards are full of Spotlight issues and Spotlight related problems. Its a great idea but not quite there yet, almost as if it was rushed into Tiger like Quartz 2 Extreme, there but not enabled.

If anyone has any ideas what could of caused my Spotlight issues please let me know. I have a 2.0Ghz Macbook and so could the problem be related to a recent security update for Intel Macs that only affects certain units?


macrumors newbie
May 16, 2006
Recently had this issue too. There was a temp hidden folder that was not hidden (missing its period '.' before the folder name). When this was deleted Spotlight seems to work fine again. There was no reason for the hidden folder to not be hidden though.