Spotlight Icon Disappeared in Leopard

Discussion in 'macOS' started by martinmartin, Oct 29, 2007.

  1. martinmartin macrumors 6502

    Joined:
    Jun 5, 2007
    #1
    Leopard had been working fine for me until this morning. Last night, when shutting down, I did software update and installed some update concerning Password Keychains. A few hours earlier, I installed some Software for my Harmony Remote and it said something like I did not have Administrative Access to the Apps folder.

    Now, Spotlight has disappeared from my Desktop - see attachment.

    I have tried all of the suggestions here: (Can't paste the link because now my Copy Paste isn't working). (OSX Daily Spotlight help page)

    What's going on here?? No spotlight, no copy paste? (I have restarted, but it didnt change anything)

    Edit: I also can't drag items from my desktop to my trashcan. I beginning to think these issues are about to snowball...
     

    Attached Files:

  2. martinmartin thread starter macrumors 6502

    Joined:
    Jun 5, 2007
  3. martinmartin thread starter macrumors 6502

    Joined:
    Jun 5, 2007
    #3
    I also can't drag items on my desktop...

    I think it might be time for a re-install. I used the 'upgrade' method to go from Tiger to Leopard on Friday...
     
  4. supafield macrumors newbie

    Joined:
    Oct 31, 2007
    #4
    Hey bud,

    I just bought a harmony remote.... and went to install the software.... it didn't go right, and now I can't reinstall msn, my spotlight has dissapeared and I can't drag.... this is a major problem...
     
  5. martinmartin thread starter macrumors 6502

    Joined:
    Jun 5, 2007
    #5
    Are you kidding?

    Wow, i guess the Harmony software is to blame. I loaded that Sunday evening and started having problems Monday morning.

    I ended up wiping my hard drive clean and reinstalling Leopard fresh. Haven't added the Harmony software again - in fact, it hasn't even crossed my mind.

    Have you tried deleting the application?

    Let us know what happens...
     
  6. hermansc macrumors newbie

    Joined:
    Nov 2, 2007
    #6
    Same here

    I have the exact same problem. I am also unable to connect my iphone and ipod - itunes says synchronization is disabled for this machine...

    Any input would be greatly appreciated...
     
  7. lofight macrumors 68000

    lofight

    Joined:
    Jun 16, 2007
    #7
    snowball?? isn't it the beackball?
     
  8. Jocee macrumors newbie

    Joined:
    Nov 10, 2007
    #8
    Another manifestation of this is the inability to connect to SMB shares on Windows.

    It turns out that the permissions of the /private/tmp directory are wrong for some reason. I don't know if this is a Logitech or Apple problem, but it is easily repaired.

    Open Applications/Utilities and run Disk Utility. Then select the Macintosh HD (or what ever your boot drive is) and click "Repair Disk Permissions".

    When done, reboot (logging out and back in may work too)..... Voila'

    :)

    http://discussions.apple.com/thread.jspa?messageID=5750271&#5750271
     
  9. hive macrumors newbie

    Joined:
    Dec 23, 2007
    #9
    same for me on my Mac Pro 8 core that I got 2 days ago (updated to 10.5.1 from factory installed 10.5). everything was working great until I noticed I couldnt screen share with it anymore from my Macbook Pro. then I noticed the Spotlight disappeared and I couldn't drag and drop files. on top of all this, Logic Pro 8 is rendered useless because it's finding a audio/midi driver conflict upon startup and I have to force quit. i'm sure all these problems are connected because they all appeared at the same time. there's no conflict in Logic, I deleted my Korg MIDI driver to make sure, the problem is still there.

    on hold with Apple Care in the meantime...

    oh yeah..I repaired permissions and it didn't fix any of the problems.
     
  10. theBB macrumors 68020

    theBB

    Joined:
    Jan 3, 2006
    #10
    It never does. :)
     
  11. glitchman macrumors newbie

    Joined:
    Nov 26, 2007
    #11
    this problem is most definitely the harmony remote software... has anyone fixed it without having to reinstall???
     
  12. hive macrumors newbie

    Joined:
    Dec 23, 2007
    #12
    I doubt it's Harmony cause I dont have it. end result for me was Apple had me do an archive and install which fixed the problem and worked out pretty well for me as I didnt lose any of my installs.
     
  13. brightbeat451 macrumors newbie

    Joined:
    Jun 25, 2007
    #13
    I had the same issue after I played with launchd

    in my situation I had to recreate link /tmp to /private/tmp and restart my mac

    use this command in terminal

    ln -s /private/tmp/ /tmp
     
  14. ianoreo macrumors newbie

    Joined:
    Jul 25, 2007
    #14
    wow this is getting annoying. i have this problem i dont even know what harmony is, nothing mentioned here has worked

    Can someone PLEASE help
     
  15. juicysauce macrumors newbie

    Joined:
    Feb 4, 2008
    #15
    Me too

    Just wanted to add my voice to the growing chorus of people experiencing this problem. Running 10.5.1 on 2.33 Core 2 Duo MBPro. Spotlight is gone and I can't drag and drop. (Not to mention other weirdness in the Finder, like not being able to copy files.)
     
  16. coocooforcocoap macrumors regular

    coocooforcocoap

    Joined:
    Sep 22, 2007
    Location:
    kathmandu, nepal
    #16

    hi all, do any of you use iceclean? it seems to run a bunch of maintenance scripts all at once and cleans up weirdees. just a thought...
     
  17. didacgil9 macrumors newbie

    Joined:
    Jun 30, 2009
    #17
    My solution to Spotlight, D&D, etc.

    I got the same problem and I did the following things (none of them working) but I found a solution (at the end of this post), and really easy.

    I was doing a complete restore from a Time Machine backup, just to inform you, but probably this problem can appear in other scopes, so just spend some tim reading the following lines anyway.

    Problems I got:
    - Spotlight was not present in the bar, and there was no way to make it appear.
    - Some keyboard shotcuts were not working
    - Drag and drop was not working
    - Copy and Paste was not working
    - Some perferences were not saved when changed

    What did not work was:
    - Create a new user and check parental control in Spotlight configuration
    - Repair permissions being inside Leopard
    - Repair permissions from Leopard Install DVD
    - Reinstall from TM again

    You can imagine, that took a lot of time and the sad thing was that none of them worked.

    What worked:
    - Check that /System/Libraries/Sportligh was existing
    - Check that ~/Libraries/Spotlight was existing (I copied from the System folder)
    - Check that /tmp folder exists and points to /private/tmp

    I'm pretty sure that the only problem was the /tmp folder. Something as easy as creating a link solved the problems from Spotlight, drag&drop, the trash issue...

    So, I just went to a terminal window, I changed into root user and I created the folder:

    > sudo su
    password: (write your administration password. If you only have one user in the machine, mostly your user is the admin, so type your own password)
    > cd /
    > ln -s /private/tmp ./tmp

    And now you only need to reboot and Spotlight will come again to the bar, and drag&drop will work again.

    I guess that those applications copy information in /tmp folder as a temporary folder to save what was draged, and so on. It's a pitty that Time Machine forgot to copy this link, because that made me go crazy.
     
  18. kjgriffin macrumors newbie

    Joined:
    Aug 31, 2009
    Location:
    Tucson, AZ
    #18

    THIS WORKED!!!!

    I had this same set of problems start suddenly late yesterday morning, after I installed the latest security update & restarted (Yes, it's weeks, old, but I'm mid-project and was trying to avoid this sort of thing). After not finding the right hints on line, I did a time machine restore (10 h) to before the problem started, to no avail. I did another restore back to the night before: still no luck. Meanwhile, I came across some aspersions against Logitech, esp. the universal remote. I don't have one of those, but then I remember that I stumbled across an application in my utilities folder the day before called Logitech Universal Controller. Foolishly, I opened it to see what it was, then since I had no wireless devices to coordinate, I quit. Perhaps that's what did me in. Still, after deleting anything Logitech-related I was out of luck.

    I was about to try yet another time machine restore further into the past, and loose significant work. Fortunately, I stumbled across this thread. The problem and solution were spot-on.

    @didacgil9: I owe you an appropriate frosty beverage (or several). Thank you!
     
  19. jameson740 macrumors newbie

    Joined:
    Oct 9, 2009
    #19
    Is there any way I can get some help on how to actually do this in order to fix my mac? Any help would be appreciated! Maybe just a phone call or chat, thanks
     
  20. eewMacBook macrumors newbie

    Joined:
    Oct 20, 2009
    #20
    Instructions

    This tread seem really helpful and address the problems I am experiencing perfectly but I am not very familiar with terminal windows, and unsure as to how to copy the spotlight from one directory to another when I can not paste. I am un idiot I know but would be a hugely appreciative one If i dont have to pay an ass at apple to explain this to me.
     
  21. kjgriffin macrumors newbie

    Joined:
    Aug 31, 2009
    Location:
    Tucson, AZ
    #21
    If you're careful, you can type the bits in the helpful post from above:


    To check that the first bits are there, start a new terminal (should be in your home directory, ~)

    Type:
    cd /System/Library [NB: not libraries]
    ls - LF [directory listing]
    check that it lists the directory "Spotlight/"​

    Type:
    cd ~/Library [NB: not libraries]
    ls -lF ​
    check that it lists the directory "Spotlight/"​

    Type:
    cd /
    ls -lF​
    Check that it lists the symbolic link: "tmp@ -> /private/tmp"

    THIS link is the bit that was missing, and the instructions above use ln -s to make a symbolic link (think: alias in finder). sudo means that you're doing this as the superuser/admin and you can do some damage if you go mucking about with what you don't understand. If you stick to the text as written, and then quit terminal afterwards, you should be in ok shape.

    I hope this is helpful. Best of luck,

    --KJG
     
  22. CheeseConCheese macrumors newbie

    Joined:
    Jul 23, 2011
    #22

    After typing cd /System/Library [NB: not libraries
    ls - LF [directory listing]
    Terminal returned 4 different lines stating that there is no such directory or file. So basically I seem to be stuck at step one, how do I create the appropriate directory? What should I do??
     
  23. undowen macrumors newbie

    Joined:
    May 8, 2012
    #23
    Dear all,

    I deleted the temporary files (from system/library) and I also emptied the trashbin (yeah, great me). I deleted the files by mistake while looking for another .exe file.

    I did all the steps that you mentioned before, all of them, twice, three times, four times and nothing.

    I verified the permits of the drive, repaired them, cleaned the cache everything possible that I've seen in many forums in the net and nothing. Reboot and still the same.

    If anyone has any idea of what I can do to drag/drop/copy/paste again, please, let know, I'm a bit desperate as you can imagine!

    Regards,

    Undowen
     

Share This Page