Spotlight in Snow Leopard won't stop indexing

Discussion in 'MacBook' started by tec2030, Oct 27, 2009.

  1. tec2030 macrumors newbie

    Joined:
    Oct 27, 2009
    #1
    I've had Snow Leopard since the day it came out. And I installed it that same day. Since then Spotlight is constantly indexing and will not stop. I noticed about a week after installation when I went to use stoplight and it wouldn't let me because it was indexing. Now fast forward to today I still haven't fixed this problem because I never really needed to use it. So no I have the need, and I need to fix this problem. Can anyone help?

    BTW I'm using a 13" aluminum Mac Book bought around June '09 the model right before the current 13" aluminum Mac Book Pro's
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    Enable Hidden Files and Folders (Run this command in Terminal.app: defaults write com.apple.Finder AppleShowAllFiles YES). Then, go to Macintosh HD (or similar) and find the folder that is called ".Spotlight-V10'". Trash this file, restart and see if that fixes the issue.

    Removing this folder completely erases the Spotlight index and Spotlight will obviously re-index once to re-create the index.
     
  3. tec2030 thread starter macrumors newbie

    Joined:
    Oct 27, 2009
    #3
    I put that command line into Terminal but what is the exact pathway to the Spotlight file? How can I even find without spotlight itself lol. Sorry, I'm new to mac, the last one I owned was about 17 years ago :p
     
  4. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #4
    It should be located right on your Macintosh HD after enabling hidden files and folders.
     
  5. davepar macrumors newbie

    Joined:
    Oct 29, 2009
    #5
    Assuming you know something about the terminal (/Applications/Utilities/Terminal.app) you can try:

    disable spotlight indexing on /

    sudo mdutil -i off /


    erase spotlight index on /

    sudo mdutil -E /


    show status of spotlight indexing

    sudo mdutil -s -a


    enable spotlight indexing of /

    sudo mdutil -i on /


    There's a bit of a quirk with spotlight in 10.6 compared to previous versions that may be affecting you. See:
    http://forums.macosxhints.com/showthread.php?t=106703
    http://forums.cnet.com/5208-6126_102-0.html?threadID=366184
     

Share This Page