Spotlight not indexing network drive

Discussion in 'Mac Apps and Mac App Store' started by SisterRay, Nov 22, 2008.

  1. SisterRay macrumors regular

    May 25, 2006
    I have an iomega network drive on which I store my itunes library. However spotlight does not find any files on this drive.

    I have tried mdutil -i on /Volumes/Network drive and mdutil -E

    It says it has turned on indexing, but it still will not find any files.

    Does anyone know how to make spotlight index this network drive, or recommend an app that will allow me to search network drives
  2. SirHaakon macrumors 6502a

    Jun 14, 2007
    I'm having the exact same problem. Any solutions would be greatly appreciated.
  3. khax macrumors newbie

    Sep 14, 2010
    Spotlight to index network folders

    There may be a solution.

    Check this story found on synology forum :


    Re: Mac OS-X spotlight index of a Synology share?

    Postby ColdFire » Thu Oct 21, 2010 9:48 pm
    Hey guys,

    Late entry from me here...

    I just found this while trying to get indexing working via spotlight. I found a couple of people saying to use the: mdutil -i on <volume path> --> to activate the indexing (I ran this under sudo bash)
    When I did this nothing seemed to happen other than searching on my NAS stopped working completely! lol

    I then ran the second command (not under sudo bash as it gave an error): mdimport -d1 <specific directory of volume to be indexed> --> to force immediate indexing

    I had already run mdutil -d before so I got a list of files streaming through terminal and it finally finished after a little while, but a lot quicker than expected considering the amount of data...

    I then tried to search again, searched for something I KNEW was on there and it shows 0 results almost instantly... I though screw this and turned indexing off again, did a search and almost instant results!? I tried several searches and they are all almost instant now...

    Anyone else got this?


    I tried it and it "works". My indexing is officially disabled, but still I can post searches and get results.

    Not all results unfortunately, but maybe indexing takes some time.

    Try it and tell me whether you have the same results !

Share This Page