Spotlight not working :(

Discussion in 'Mac Basics and Help' started by Blue Velvet, Jun 7, 2007.

  1. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #1
    It's not finding anything, not even files on the desktop. It's not indexing the drive. It's doing sweet eff-all, it's doing squat. :mad:

    I've restarted. Twice.

    MBP 17" C2D, 10.4.9

    Would really appreciate some help or suggestions, Spotlight is crucial to me for searching emails and PDFs.

    Many thanks
    BV
     
  2. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #2
    Code:
    sudo mdutil -E /
    in terminal should do the trick. It deletes the index forcing a rebuild of the index.
     
  3. Blue Velvet thread starter Moderator emeritus

    Joined:
    Jul 4, 2004
    #3
    Thank you so so so much. :)

    It's doing its thang right now. It'll take about 30 mins or so.

    <immensely relieved> :D
     
  4. Blue Velvet thread starter Moderator emeritus

    Joined:
    Jul 4, 2004
    #4
    Er... no, it's still not working. It said the disk was indexing, that's stopped, but still nothing. :(

    Verified and repaired permissions as well. Nothing's in the Privacy section of Spotlight's preferences.
     
  5. Blue Velvet thread starter Moderator emeritus

    Joined:
    Jul 4, 2004
    #5
    Sorry to commit the sin of bumping or triple-posting... but anyone? :eek:
     
  6. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #6
    Try this.

    Move the spotlight plist file to your desktop and restart.
     
  7. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #7
    Not very helpful, I fear, but I can run through a couple of basics:

    - Does it work from another user account? If so: the culprit may be something like the com.apple.spotlight.plist file in your users preference folder: ~/Library/Preferences/com.apple.spotlight.plist

    - Have you tried the manual version of the Terminal trick above: Go into System Preferences -> Spotlight -> Privacy and add and then remove your HD?

    - Have your tried some of the usual mumbo jumbo: Repair permission, verify disk, deleting caches, etc? Main Menu is good to have sometimes...

    (BTW, wasn't there reports of a problem - a while back - with Spotlight not finding files on the Desktop?)
     
  8. Blue Velvet thread starter Moderator emeritus

    Joined:
    Jul 4, 2004
    #9
    Thanks gents. :)

    I'l try these out tonight when I get home. :)
     
  9. Kernow macrumors 65816

    Kernow

    Joined:
    Sep 30, 2005
    Location:
    Kingston-Upon-Thames
    #10
    I had a similar problem a while back. I tried all of the above, plus a couple of other terminal commands which I found in old threads here (I'll see if I can find them again), and nothing worked.

    In the end, I did an archive and install, which did the trick, but messed up a couple of my other apps, meaning I had to reinstall them - notably Photoshop CS2. Living without Spotlight made me realise just how useful it is.

    Not spectacularly helpful, but if all else fails...

    Edit: Courtesy of the lovely Mad Jew, this is the other command I tried.
     
  10. whooleytoo macrumors 603

    whooleytoo

    Joined:
    Aug 2, 2002
    Location:
    Cork, Ireland.
    #11
    This happens on both my Macs periodically; I either use the command line above or (if I'm lazy) add, then remove, the hard disk from the Privacy list in the Spotlight control panel.
     
  11. Blue Velvet thread starter Moderator emeritus

    Joined:
    Jul 4, 2004
    #12
    Are both your Macs Intel? I've never seen or had this problem on PPC versions of Tiger...
     
  12. Blue Velvet thread starter Moderator emeritus

    Joined:
    Jul 4, 2004
    #13

    Thanks all, for your help. :)

    This suggestion worked like a charm:

    Solution #1: Kill SystemUIServer

    • Launch ‘Activity Monitor’ (located in /Applications/Utilities/)
    • Locate the process ‘SystemUIServer’, highlight it, and click the red button “Quit Process” (I had to do Force Quit here)
    • Within a few seconds the menubar will rebuild itself and often Spotlight will magically work

    Hopefully, 10.4.10 will fix this.
     
  13. nsvalera macrumors newbie

    Joined:
    Jul 9, 2007
    #14
    Kick starting Spotligth and/or Finder

    I find the following approach successful in kick starting Spotlight and/or Finder when they fail to work for some mysterious reason(s).

    1. Download the OnyX multifunction utility. Make sure that the Onyx version is compatible with your OS.
    2. On booting, and you discover that Mac and/or Finder do not work, proceed to item 3.
    3. Click on the OnyX icon. It then asks " Verify startup volume". If you are in a hurry (verification takes a few minutes), just click "cancel".
    4. OnyX will then prompt you to type your password.
    5. On the main page, click on "Parameters" icon. In the page that is opened, click "Restore Defaults".

    Hope these help.
     
  14. zub3qin macrumors 65816

    zub3qin

    Joined:
    Apr 10, 2007
    #15
    I have problems with Spotlight as well.
    I did all the recommended fixes- it fixed to a point... but any NEW files don't seem to get indexed into spotlight.

    The weird thing is that emails which arent found in Spotlight, are found in the Mac Mail spotlight section. And programs not found in the desktop spotlight, are found in the Finder spotlight (only when I search in HOME, not in COMPUTER)

    1) Why is this happening?
    2) What is the difference with HOME and COMPUTER in regards to searching?
     
  15. DannyTheManny macrumors newbie

    Joined:
    Jul 24, 2007
    Location:
    Ireland
    #16
    I too am experiencing these Spotlight woes. Though for me I can find anything as long as I re-index the main volume every time I create a new file. So it's effectively useless, which is a shame as I've a number of research projects at the moment which could benefit from the metadata tagging system used by QuickSilver.

    I've tried everything from the simple Privacy trick, to using the Terminal to delete the Index, re-create the index, and toggle indexing off and then back on. All to no avail. It seems as if some Macs just don't have a functioning Spotlight. The Finder thing mentioned earlier does not occur for me: Spotlight will only find new files or files with a tag when the whole volume is reindexed. I'm just about to give up, as the only thing I can think of that <i>may</i> change things would be a fresh install of OSX *shudder* never thought I see the day when I said that about a Mac instead of a PC.
    Any ideas folks? Please respond :)
     
  16. zub3qin macrumors 65816

    zub3qin

    Joined:
    Apr 10, 2007
    #17
    Well I am convinced that Spotlight is broken. I tried for hours to fix things like you did- in terminal, in spotlight prefs.... to no avail. Any new file doesn't get added to the spotlight index (actually only mail and stuff on the desktop- new apps and stuff placed in other folders seem to index themselves).

    I plan on living with it for 2 more months... just reindex every week or so.
    Once Leopard comes out, I HOPE spotlght is fixed.

    I am just glad I am not the only one with this problem (which to be honest with you made me feel like I was trying to fix my old Windows laptop looking for solutions online, typing in esoteric commands in terminal, etc).
    Listen up Apple!
     
  17. DannyTheManny macrumors newbie

    Joined:
    Jul 24, 2007
    Location:
    Ireland
    #18

    Indeed, it must be a fault with spotlight that randomly happens. Yeah, looks like the only thing we can do is sit back, wait, hope, and pray that Leopard fixes it. All in all, it's been an uncomfortable reminder of why I left Windows based machines behind. But such is life I suppose
     
  18. nzmc36 macrumors member

    Joined:
    Jun 5, 2006
    Location:
    Gainesville FL
    #19
    Thanks, I had the same problem (1 week old 24" iMac 2.8 GHz)... all is good again. Rather odd tho', I've been a Mac user for 6 years and never had this happen, let alone to a new machine. Other than that, all is great apart from Parallel/XP issues.
     
  19. Digifreak macrumors newbie

    Digifreak

    Joined:
    Oct 28, 2007
    #20
    Bahhh!

    Leopard's working like a dream, but keywords in iPhoto can't searched in spotlight, making it useless for me - I have 20,000 key-worded photos.

    I have tried all the tiger fixes, but it simples fail to see all (but a few) tagged files.

    Anyone else get this?
     
  20. macbouncer macrumors newbie

    Joined:
    Feb 10, 2010
    #21
    Sorry all I know this is an old thread but I am dying here. My problem is that the indexing never finishes (57 hours estimated time!!). The problem arose when I swapped out the HDD for a new model and used time machine to restore. Worked a charm apart from spotlight. I have used all the tips above, repaired permissions but no joy. When I repair disk I was getting a lot of ACL issues but according to apple I can ignore these BUT I still got rid of them using ACLr8 but still no improvement. I am at my wits end!!
    Running 10.5.8 MBP 12"
     
  21. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #22
    old thread - same problem.

    a work server is being effected by this, has multi TB of data stored on it. has anybody any idea how to fix this in 10.6? reindexing TB of data every few days is not feasible nor efficient.

    thanks
     

Share This Page