Spotlight searching others users email

Discussion in 'macOS' started by Evangelion, May 3, 2007.

  1. Evangelion macrumors 68040

    Joined:
    Jan 10, 2005
    #1
    I had a bit of a shocker-situation yesterday. I was showing my wife how convenient Spotlight could be. She was logged in with her username, and I asked her to search for my name and... It found and displayed bunch of email residing in my inbox.

    Now, how do I stop that? Yes, I trust my wife and all that, but I still don't like the idea that someone might be going through my email. Call it a principle or something.

    And, as it happens, my Spotlight does not search my wifes email. So obviously it can be done.
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Can you access your account's files form your wife's account in the Users folder? Click on your account there and press COMMAND-I to check the permissions. :)
     
  3. SC68Cal macrumors 68000

    Joined:
    Feb 23, 2006
    #3
    that should not be possible, unless the permissions were changed. Even an Admin account cannot display spotlight results for other user's files, by default.

    Perhaps either she or you accidentally downloaded some of your e-mails to her account?

    Where do the emails that showed up in spotlight reside? If you tell us the file path (users/yourname/library/mail) we can get the permissions and see if that has been fubar'd
     
  4. Evangelion thread starter macrumors 68040

    Joined:
    Jan 10, 2005
    #4
    Sorry for late reply. Anyway, I looked in to it, and it seems that my wife has (for some reason) access to my library-folder, whereas I do not have acces to hers. I have no idea why that is, it might be related to earlier settings where I shared one iPhoto-library between two of us. Now, the question is that how do I stop it? I can see that she has access in the Get Info of my library-folder, but I can't remove her access to that folder from there. Where can I do that? What I did manage to do is that prevent her from accessing my home-folder altogether, and that fixed the issue. But why ouldn't I just change the settings of the Library-folder?
     
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    In the Get Info panel, you should be able to change the Ownership & Permission section of your account from her account such that she can't access it anymore. Apply the changes to enclosed items too. :)
     
  6. Evangelion thread starter macrumors 68040

    Joined:
    Jan 10, 2005
    #6
    I can't. It shows the permissions, and if I expand the view through the little arrow, it displays my wifes username and the rights she has to the folder. But I can't change any of them
     
  7. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #7
    This is form your wife's account, right? Is the padlock locked? It may need to be unlocked first. If this doesn't apply, then maybe post a screenshot of the Get Info panel for us. :)
     
  8. Evangelion thread starter macrumors 68040

    Joined:
    Jan 10, 2005
    #8
    It's from my account. I'll try to come up with a screenshot for you guy later today :).
     
  9. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #9
    Okay, well do it from her account and you should be right. :)
     
  10. Evangelion thread starter macrumors 68040

    Joined:
    Jan 10, 2005
    #10
    I don't think that I can do it from there either. The permissions-field of that folder looks different from other folders, maybe I'm not the owner of that folder somehow? See screenshot.
     

    Attached Files:

  11. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #11
    Was that screenshot from your account, or hers?
     
  12. Evangelion thread starter macrumors 68040

    Joined:
    Jan 10, 2005
    #12
    Mine. "Janne" (as in /Users/janne) is me, and "soili" is the wife.
     
  13. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #13
    Right, well get her to log in and change the permissions form her account. Alternatively you could change the permissions from Root User but it's probably safer to do it from hers. If you use Root User, disable it afterwards. :)
     
  14. bankshot macrumors 65816

    bankshot

    Joined:
    Jan 23, 2003
    Location:
    Southern California
    #14
    I'd say there's no need to use the root user. Disabling that account completely was one of the few things Mac OS X got right with respect to elevated privilege users.

    It appears that the Library folder may not be owned by you (the original poster) when obviously it should be. The other possibility here is that you've turned on ACLs (access control lists) and it has a weird set of ACLs. Frankly, I've never seen the "Ownership & Permissions" area of the dialog look the way it does in your screenshot. It looks totally different for me. I even tried enabling ACLs and my dialog still looks the same as it ever has. :confused:

    The easiest way to fix this (from my perspective, anyway; I'm a unix person, so keep that in mind :D) is to open Terminal while logged in as an admin user. Then simply type:

    sudo chown janne /Users/janne/Library
    sudo chmod 700 /Users/janne/Library

    Finally, in case the problem is ACLs, you can delete any ACLs on the folder by repeating the following command until you get an error message telling "No ACL present" (just hit up-arrow to get the previous command):

    sudo chmod -a# 0 /Users/janne/Library

    Hopefully that does it.
     
  15. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #15
    Yeah, Root User shouldn't be necessary but I mentioned it in case he wants the changes now and doesn't have access to his wife's account in the short term. :)
     
  16. Evangelion thread starter macrumors 68040

    Joined:
    Jan 10, 2005
    #16
    Yes, I have definitely turned on ACLs, since I need it to share a single iPhoto-library between me and my wife (it works BTW). And I guess that while I was doing the sharing, the permissions got screwed up somehow. I'll take a look at your suggestions and see if I could fix it. Last time I used chmod was with Linux ;).

    EDIT: OK, I managed to lose the wife from the Library-folder, but the permissions-options still look different from normal. It looks like in the screenshot, apart from my wife being missing.
     
  17. Evangelion thread starter macrumors 68040

    Joined:
    Jan 10, 2005
    #17
    I made a thred about this in the Apple Support-forums as well, in case you are interested: Link
     

Share This Page