Spotlight shortcut won't work

Discussion in 'macOS' started by larsting, Feb 14, 2009.

  1. larsting macrumors newbie

    Joined:
    Feb 14, 2009
    #1
    Hi!

    I'm new here and quite new to mac as well.

    Until now I've used the shortcut for spotlight (ctrl-spacebar) a lot. But suddenly it doesn't function any more. When I go to the preferences and hint the spotlight-icon, nothing happens. If I click it again, it opens, but with the shortcut selections in the bottom erased.

    I have a Intel Leopard 10.5.6 MacBook.

    Can anyone help?

    Thanx


    lars
     
  2. kolax macrumors G3

    kolax

    Joined:
    Mar 20, 2007
    #2
    I assume you were confused when you said CTRL+Spacebar - you mean CMD+Spacebar?
     
  3. larsting thread starter macrumors newbie

    Joined:
    Feb 14, 2009
    #3
    Well - you can assign either CTRL+Spacebar or CMD+Spacebar to do the job. :) The problem is, that none of them functions in my OSX...
     
  4. TJJ macrumors newbie

    TJJ

    Joined:
    Jan 26, 2005
    Location:
    Bern, CH
    #4
    Fixed yet?

    Did you get to fix the problem?

    Same for me: assigned shortcut doesn't work, if i click on "Spotlight" in preferences it says "loading" (but it doesn't), I have to click it twice...

    Also: Spotlight doesn't "find" applications (activated in preferences).

    Brand new MacBook Pro 15", up to date...

    Any ideas?
     
  5. marvin*1*2 macrumors member

    marvin*1*2

    Joined:
    Jun 19, 2007
    Location:
    Yrp!
    #5
    same problem

    i have the same problem...
    every once in a while, pressing cmd-spacebar does not invoke spotlight search anymore.
    only after going into sys-preferences - keyboard shortcuts to reset the shortcut for spotlight (cmd-spacebar) again, it works for another while...

    also, pressing the spotlight icon in sys-prefs also doesn't work anymore unless I go someplace else first in the sys-prefs.

    I have a feeling this problem appears since 10.5.6 ... :confused:
     
  6. joejoejoe macrumors 65816

    Joined:
    Sep 13, 2006
    #6
    Hi,

    Same problem here and it started very recently. I get the error alert sound when I hit CMD space and when I go to spotlight preferences, the shortcut area is blank and even if I select CMD space it'll go blank the next time I open it up.

    What's goin on guys?
     
  7. joejoejoe macrumors 65816

    Joined:
    Sep 13, 2006
    #7
    fixed it

    did a software update and it did the trick. I'm guessing it was updating to 10.5.7
     
  8. RawFisher macrumors newbie

    Joined:
    Jun 16, 2009
    #8
    Called apple and got it solved...

    Hi Everyone. Yesterday I got my new MacBook Pro (YEEHHAAA), migrated all mi data and checked my essential files via Spotlight, for which I used the shortcut Command+Spacebar.

    Then, I did the updates... since it was brand new it took a bit to download all the new thingies needed. I guess it updated to 10.5.7.

    After the update my Spotlight shortcut stopped working. It wouldn't work if I went to Preferences and hit Spotlight, here it would "Load" forever, until I clicked spotlight again. Then I'd assign a shortcut, but as soon as preferences were closed it disappeared.

    So I called apple and after a few automated questions someone picked up; I told him the issue; he put me on hold for a couple minutes and came back with the solution.

    Apparently a recent update (10.5.7?) resets the Keyboard shortcuts. So, go to Preferences/KeyBoard & Mouse, Scroll down to Spotlight; it should be unchecked. Well, check it... sit back, and enjoy the ride. :)

    Cheers!
     
  9. we-design macrumors newbie

    Joined:
    Jul 3, 2009
    Location:
    Germany
    #9
    Solution for the Spotlight Shortcut thing

    Hi there, I've had exactly the same problem. But now i found a solution that seem to work!

    - After klicking the Spotlight Menu-Item twice (once<- it doesn't apear), I disabled the two Spotlight Shortcut Checkbox's and returned to the sys-pref. then I was able to get back into the Spotlightmenu by single-clikcing (YEAH). Well, all changes I made in the menu were saved (the disabled boxes), so I re-activated them and set the Spotlight shortcut back to "CMD-Spacebar". After returning back to the Sys-Pref. the Spotlight Shortcuts were working again!
    (and till does :D)

    Good Luck, Tobi
     

Share This Page