Spotlight slows startup

Discussion in 'macOS' started by MatthewCobb, Jul 9, 2007.

  1. MatthewCobb macrumors regular

    Joined:
    Jun 7, 2005
    Location:
    Manchester, UK
    #1
    For about 3 weeks now my MacBook is taking about 20-30 secs more to startup. After all the finder loads and all the icons are visible except those in the top right of the finder bar (airport etc), the machine just stops doing anything you can see, then eventually (30s later) loads the final applications (airport etc) and proceeds as normal. I assume this is due to Spotlight, as if I move the mouse over the spotlight icon, I get the spinning beachball of death (this goes when I move the mouse away, but I can't click on anything while the machine is doing whatever it's doing).

    I have reduced the number of folders Spotlight is indexing to the bare minimum, (ie those with documents in), but this has made no difference. I only have stickies loading on startup, so it's not some unknown programme hogging stuff.

    I did the upgrade to 10.4.10, but have also done this on my iMac, which does not suffer from the same irritating problem. Those 30s are precious!

    And yes, I turn my Macs off rather than putting them to sleep. Part of a general campaign to lower those carbon emissions...

    Any suggestions for how to fix this?
     
  2. janey macrumors 603

    janey

    Joined:
    Dec 20, 2002
    Location:
    sunny los angeles
    #2
    it's actually SystemUIServer that's being slow, not spotlight, but I can't really think of a reason why...
     
  3. MatthewCobb thread starter macrumors regular

    Joined:
    Jun 7, 2005
    Location:
    Manchester, UK
    #3
    Have just unchecked Stickies as login item and time is now reduced to a-much-less-irritating 5 secs (presumably due to a couple of Microsoft updaters that reinstall themselves). So mystery half-solved. And yes, have already repaired permissions (twice), to no avail.
     
  4. Eric Lewis macrumors 68020

    Eric Lewis

    Joined:
    Feb 4, 2007
    Location:
    CANADA? eh?
    #4
    any

    easy way to kill dashboard? its hogging all of my 384mb ram on my 1ghz eMac
     
  5. live4ever macrumors 6502a

    Joined:
    Aug 13, 2003
    #5
    Try holding down the 'shift' key when you log-in, this will disable any 3rd party login items (they are usually the things that slow down the login process).
     
  6. a cat *miaow* macrumors regular

    Joined:
    Jun 12, 2007
    #6
    Not sure it's the same thing but I have this problem whenever i update the OS, i have lots of fonts which on every update decide to make themselves ALL active.. pah.. so maybe check how many fonts are open & running?
     
  7. janey macrumors 603

    janey

    Joined:
    Dec 20, 2002
    Location:
    sunny los angeles
    #7

Share This Page