spotlight stopped working

angee

macrumors newbie
Original poster
Jun 2, 2005
2
0
hi
Spotlight was working fine; then just stopped.

I haven't changed any settings. Does anyone have any ideas?

I can type words into the dialogue box, and nothing happens.

Thanks.
Angela
(new mac mini user -- Windows convert)
 

tag

macrumors 6502a
Apr 29, 2005
918
9
Have you checked the Spotlight preference pane? I know you said you didn't change any settings yourself, but perhaps something got changed you weren't aware of? Make sure you local HD isn't listed under the 'Privacy' tab, and that all the categories under 'Search Results' are checked off. If thats all fine, only thing I could think of is perhaps something happened to your Mac's spotlight indexes, which Im not sure what needs to be done to fix that.
 

Chrispy

macrumors 68020
Dec 27, 2004
2,126
1
Indiana
I'm having a similar problem myself.... if anyone knows how to force spotlight to index the drive please let me know. Thanks
 

mackaveli

macrumors regular
May 1, 2005
156
0
to index the drive go to spolight preferences> privacy

add the main drive macintosh HD, then remove it and then spotlight should reindex it
 

Blabberlicious

macrumors newbie
Jul 5, 2005
3
0
mackaveli said:
to index the drive go to spolight preferences> privacy

add the main drive macintosh HD, then remove it and then spotlight should reindex it

If only.

Trying to add/remove Folders to the Spotlight search preferences fails too.

If I drag the HD icon to the privacy panes, I get a spinning beach-ball for a few seconds, then nothing.

So now I have no means for find anything on my mac.

Cutting edge stufff.

I should add that, previously, Spotlight had 'died' when I tried to upgrade from to Tiger from Panther.

This was a clean install.

really poor.
 

Sedulous

macrumors 68020
Dec 10, 2002
2,337
1,585
The only way I know to force spotlight to reindex is to delete the .Spotlight-V100 file in your root directory.
 

Blabberlicious

macrumors newbie
Jul 5, 2005
3
0
Sedulous said:
The only way I know to force spotlight to reindex is to delete the .Spotlight-V100 file in your root directory.
No good.

Tried that.

Spotlight starts rebuilding, but stops after 2 mins. Then can't find anything.

I feel an archive reinstall coming on - no time to do a wipe.
 

jelloshotsrule

macrumors G3
Feb 7, 2002
9,591
3
serendipity
rather than starting a new thread i dug this up from the grave... anyone have any new ideas on how to force spotlight to index? it's quite possible i missed a more recent thread/post that had more options; if so i'm sorry...

basically i have the same problem as blabberlicious:

spotlight worked, then stopped (not sure if it coincided with a software update of any sort)

it will not allow me to add anything to the privacy list. beachball spins for a bit and then no results.

i haven't tried the deleting that file, but will try it tonight when i get home... any other options?
 

Johnny Rico

macrumors 6502
Feb 17, 2005
267
0
Spotlight is bunk. It indexed my drive when I installed x.4 but whenever I do a search for anything, the results it comes back with include about half the files on my hard drive.
 

jelloshotsrule

macrumors G3
Feb 7, 2002
9,591
3
serendipity
so i tried a whole bunch of command line stuff yesterday, and it could never do anything with the spotlight index. always gave me an error on the various commands.

i eventually deleted the spotlight directory folder on one of my hdds and when i restarted it indexed. however, i still get no search results from it! weird.. i'll try some more stuff today probably.
 

jelloshotsrule

macrumors G3
Feb 7, 2002
9,591
3
serendipity
so i did some command line stuff that turned off spotlight on a global scale... then i deleted all the index folders, then i turned spotlight back on (editing some "VI"?) and restarted..... and bam! everything re-indexed and works again

just in case someone else has a similar problem.
 

crazzyeddie

macrumors 68030
Dec 7, 2002
2,790
0
Florida, USA
jelloshotsrule said:
so i did some command line stuff that turned off spotlight on a global scale... then i deleted all the index folders, then i turned spotlight back on (editing some "VI"?) and restarted..... and bam! everything re-indexed and works again

just in case someone else has a similar problem.
Can you be a little more specific? :p

I've tried forcing Spotlight to re-index using the terminal, but what commands did you use to turn it off and back on, etc... I really don't want to do an Archive and Install, its finals week :(
 

studiovisive

macrumors newbie
Apr 29, 2006
1
0
spotlight stopped working

Greetings, I had this same problem and it is because I installed shapeshifter from unsanity.com. Actually the problem is with the application enhancer that is needed to run that app. As soon as I uninstalled shapeshifter and the application enhancer and viola.... spotlight works, and i can see shared printers again!
 

me_94501

macrumors 65816
Jan 6, 2003
1,009
0
studiovisive said:
Greetings, I had this same problem and it is because I installed shapeshifter from unsanity.com. Actually the problem is with the application enhancer that is needed to run that app. As soon as I uninstalled shapeshifter and the application enhancer and viola.... spotlight works, and i can see shared printers again!
Except spotlight runs as root and APE won't affect root processes. They aren't related. Also, the console clearly says what file it was working on when the indexer crashes (at least most of the time).