Spotlight web content process is causing MacBook to slow/freeze every time Spotlight

Discussion in 'OS X Yosemite (10.10)' started by sosaysi, Apr 30, 2015.

  1. sosaysi macrumors newbie

    Joined:
    Aug 22, 2012
    #1
    Recently, every time I do a spotlight search my computer starts heating up and going very slow or freezing. I checked Activity Monitor and realized it's because Spotlight is launching a process called Spotlight Web Content that for some reason starts consuming 50%+ of my CPU and upwards of 500MB of RAM. Sometimes it automatically quits after a few minutes, but most of the time I have to go to activity monitor and force quit the process.

    I know that Spotlight Web Content is used for the suggestions in the new spotlight search, so I went to System Preferences and unchecked "Allow Spotlight Suggestions in Spotlight and Look up" as well as "Bing Web Searches". Yet this has not resolved the problem. I also tried repairing my permissions in Disk Utility, to no avail.

    Finally, I tried turning off the Safari preference to include Spotlight search suggestions. Still not working.

    Any ideas on how I can get Spotlight Web Content to stop running?



    MacBook Pro with Retina display, OS X Yosemite (10.10.3)
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    I believe you need to disable it here in Safari also.

    [​IMG]
     
  3. sosaysi thread starter macrumors newbie

    Joined:
    Aug 22, 2012
    #3
    Yes sorry I wasn't clear on that but I already did try unchecking those preferences in Safari.
     
  4. Kiwi 99 macrumors regular

    Kiwi 99

    Joined:
    Apr 4, 2011
    #4
    I was researching this very same question and found an answer that works.

    System Preferences > Spotlight > Search Results Tab > UNTICK "Bookmarks and History"

    Then quit and restart Safari. Might take half a minute for some of the processes to go away. From then on, you won't see these processes again.
    Helps a lot with battery life too, to not be always doing that extra unnecessary work.
     
  5. sosaysi thread starter macrumors newbie

    Joined:
    Aug 22, 2012
    #5
    Thanks for the suggestion. Unfortunately I'm still having the same problem after unchecking the Bookmarks and History option in Spotlight preferences. Any other ideas?
     

Share This Page