SpringBoard Crash Loop - No Safe Mode - How to Fix

Discussion in 'Jailbreaks and iOS Hacks' started by scottuf, Jan 22, 2010.

  1. scottuf macrumors 6502

    Joined:
    Feb 2, 2009
    Location:
    NPB, FL
    #1
    Last night I re-jailbroke my phone to try and get rid of an unknown battery drain issue. All went well until I tried to reinstall my Cydia apps. After queuing about 5 or so apps, installing them, and respringing, my iphone went into a loop where SpringBoard would not load, the MS SafeMode prompt would not popup, and basically my phone was dead (well not dead, SB kept crashing every 10-20 seconds or so, quite annoying). After spending about 2 hours on Google and everywhere, I finally got rid of the offending app and didn't have to restore to fix it. I figured I'd give a summary to help anyone out there who might ever run into a similar issue.

    To start with, I always install SSH first thing, so that wasn't a problem, and eventually saved me.

    I didn't have syslog running yet, as I was only in the "c"'s of my app reinstall. That was a problem. Googling I was able to find a guide on BigBoss to get that running: http://thebigboss.org/guides/enable-syslog-on-2x-for-debugging/ Guide say OS2, but worked fine on 3. Lesson Learned - install syslogd with ssh first thing before any other apps!

    once I had that running, I could find the offending app (I think). Looks like a file I installed probably didn't install all of the dependencies since it was just a plugin for the app - Lesson Learned - install the app before installing the plugins, even if its out of your alphabetical install order :)

    Next I figured out from google how to use dpkg and apt-get to uninstall the offending app from here: Great!!! Problem is I didn't have apt-get on the phone so I couldn't uninstall :( Lesson Learned - install APT 07 Strict along with SSH and syslog.

    At this point I was quite dejected, but still didn't want to restore and start over. Then the little light bulb popped up over my head and I fixed all.

    I ssh'd and navigated to /Library/Mobile Substrate/DynamicLibraries/ Once there I deleted the offending app files, and upon the next SB crash, it rebooted just fine :D I was sooo happy at that point.

    Of course there are those of you out there who would have known to go there first and do that, but googling "Springboard crash loop" or any other combination of terms did not help, and googling "manually uninstall cydia app" only really found the apt-get method or other ways from the springboard, so I was out of luck. Therefore the reason I put this together is to help anyone else who might run into this issue and can't find a solution other than to restore.

    The keys are to get the tools onto the phone first thing before installing anything else. Had i had syslog running, and apt-get on there, i probably would have saved an hour of headaches. Lesson learned!
     
  2. JonNuttNTL macrumors newbie

    Joined:
    Nov 23, 2008
    #2
    Think this happened to me last Saturday, I managed to brick my 3G 5 times (would get the apple logo up then the spinner for two seconds and then it would reboot) and still can't work out what broke it! I restored each time and have a stable OS but not with all my JB apps. What app and plugin did it for yours?

    J.
     
  3. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #3
    You didn't brick your phone ! :cool:

    That misnomer is way overused by persons who don't have enough experience ! :rolleyes:
     
  4. scottuf thread starter macrumors 6502

    Joined:
    Feb 2, 2009
    Location:
    NPB, FL
    #4
    Agree, your phone's not bricked. Need more info on what you installed thru Cydia, or did you even get that far? Can't tell if this is happening immediatly after the JB (what did you use, btw? pwnage tool? blackra1n? etc).

    for me i think the offender was installing clock plugin for lockinfo before installing lockinfo. talking to david (stimpy, the developer) he thinks it may be an issue with the licensing code, but he couldn't replicate so not sure 100%
     
  5. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #5
    An iPhone that is bricked is, by definition, incapable of being restored. Your phone was not bricked, it was in a boot loop. There is a big difference.

    Incidentally, it is not possible to brick an iPhone 3G or 3GS.
     
  6. linhrom macrumors newbie

    Joined:
    Jan 7, 2010
    #6

    amazingly, your "tutorial" is the only solution to SB crash. Happend to my iOS 4 as well. Must be cause by one of the cydia apps, as I've just install iOS 4 few hours ago. And yours is the solution, i was so about to restore the whole damn thing. Thanks so much!!!!
     
  7. danyelle44 macrumors newbie

    Joined:
    Jan 14, 2011
    #7
    To Scottuf PLEASE HELP!!

    To scottuf,
    my phone keeps saying that the springboard has crashed every 5 minutes or so when im using it, and then kicks me out to the password screen. I just had my phone jailbroken and i need to know what to do.
    Your explanation looks like it would work, but because i dont know anything about cydia or anything but the basics on the iphone im really confused.
    Could someone give me a step by step way to do it????

    Thanks!
     
  8. yosefred macrumors newbie

    Joined:
    Jan 31, 2011
    #8
    wow

    your an iphone life saver :) using ur method, i was able to see what i intalled and WHEN... the thing that was crashing my SB was a backboard theme, so i couldn't delete it in cydia. (or at least couldn't figure our how to )
    thanx, like a lot..
    i worked so hard to find a solution, and deleted (unnecessarily) a lot of cydia apps... and your method just, worked... thanx
     
  9. Vict0r macrumors newbie

    Joined:
    Jan 16, 2012
    #9
    Same Problem

    :( just upgrade my iphone 4 to 5.0.1 first thing installed :
    mobile sustrate
    SSh
    mobile terminal
    SbSettings .
    How ever it seems like my phone does not have safe mode cuz when i turn on SBSettins in notifications, SB crashing over and over. I cant do SSH to delete the offending app. cuz SP is crashing everysecond
    I've been tried I-funBox with out succesfull
    my phone has mobile sustrate to be protected but it just does not work.
    I need advice. thanx
     
  10. redbeard331 macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #10
    I had my phone go into one of these infinite crash loops last week after installing a tweak, I was able to fix it with iFunBox, couldn't access SSH in safe mode. Once I found the file it was in I just deleted it and then after it re-started again it worked fine.
     
  11. Vict0r macrumors newbie

    Joined:
    Jan 16, 2012
    #11
    cant use iFunBox

     
  12. Makavelioxs macrumors newbie

    Joined:
    Feb 13, 2013
    #12
    Springboard crash loop

    I had the big problem when installed some ****** app from cydia.
    Could not get in my iPhone ---> popular "Springboard crash loop".
    Your solution inspired me, but fixed my problem on different way.
    Through wonderful iFunBox. You can do a lot with that program.
    So I've navigated to /Library/MobileSubstrate/DynamicLibraries/
    Once there, I deleted the ****** app, restarted my iPhone, and problem was gone.
    It's true, tools are important, but iFunbox, isn't it also a tool ;)
    In my case it helped me a lot.

    Greets & Thx
     
  13. iceslayer macrumors newbie

    Joined:
    May 10, 2013
    #13
    Problem with SB

    Hi there, well i got the same problem i guess, i downloaded an app from cydia(lockscreen thing),next day the iphone crashed, i already have a problem with the IOS forcing me to redsnow reboot the device every time i turn it down(I.OS 5 i guess), being a newbie i really don't know how to do to repair it so would anyone post a tutorial explaining what should i do, knowing that i can't neither turn it down nor enter the cydia and to verify the SSH thing.
     
  14. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #14
    What iOS version is your (I assume) 3GS/4?
     
  15. cobbyco macrumors 6502a

    cobbyco

    Joined:
    Aug 6, 2012
    Location:
    UK
    #15
    Easy temporary fix allowing access to the device:
    When booting, hold the volume up key on the device's side to disable all Cydia tweaks. You can still access Cydia to uninstall tweaks that you think are causing the problems.
     
  16. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #16
    That's assuming he has the version of mobilesubstrate that supports this feature.

    @OP: if this works, uninstall the lock screen you installed
     
  17. iceslayer macrumors newbie

    Joined:
    May 10, 2013
    #17
    well i have an iphone 4 iOS 5, i figured out how to go through the database of the phone from the PC by using ifun box and itools, i uninstalled every app i downloaded these days(apps from cydia) from the library but still doesn't work, still having the loot over and over,is there any other file where the deficients files could be? or any other way to fix it?

    thanks
     

Share This Page