Sqlite iPhone simulator vs IOS Device

Discussion in 'iOS Programming' started by graydog7, Jun 23, 2011.

  1. graydog7 macrumors newbie

    Joined:
    Jun 23, 2011
    #1
    Hi, I'm putting a database app together using SqLite with the latest Xcode 4.2 (Build 4C104). I'm using IOS 5 beta on an iPhone4.

    When I run the App on the simulator everything is fine but when I select the iPhone and run it I get a blank tableview on the iPhone and an sqlresult of 1 in the Xcode output window.

    Checking the doc's it seems that "Sqlresult 1" is a no database error, so I think the database is not being copied to the phone. The database IS in the project resources tree, So i'm wondering if there is something I need to do to deploy it to the phone with the App? I've spent ages going over the options in Xcode and the Organiser but I can't find anything.

    Then again, it might just be that it's not entirely compatible with IOS 5 yet?

    Can anyone help me with this one?
     
  2. justinmfischer macrumors newbie

    Joined:
    Jun 24, 2011
    #2
    Confirmed

    I'm having the same issue. Anyone have any further information on this?

    -Justin
     
  3. graydog7 thread starter macrumors newbie

    Joined:
    Jun 23, 2011
    #3
    For me this was an Idiot mistake!! I eventually noticed that the name of my database started with a capital letter, but in my code I'd used all lowercase.

    What's a bit irritating is that it worked OK on the simulator. the real IOS device is obviously much stricter about that.

    Hope this is what's causing your problem.

    GH
     
  4. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #4
    Most people have their HFS+ drives on their Macs formatted as case-insensitive but case retaining. What you described works on this sort of FS. The iPhone is case-sensitive.
     

Share This Page