iPad Square Card Reader Not Working

Discussion in 'iPad' started by jinsan, Feb 22, 2013.

  1. jinsan macrumors newbie

    Feb 22, 2013

    I was wondering if anybody has a similar problem or any tips to solve the problem.

    I've been using Square Card Reader for about 3 weeks and all sudden, it stopped reading the cards. When I plugged in the reader, it says "Reader Connected" but it just doesn't read the card.

    I've emailed Square customer service several times but always the same answers, reinstall the apps, restart iPad, etc etc... nothing works.

    Reader works fine on my iPhone so I don't think it's a reader problem.

    Any advice highly appreciated !
  2. Aspasia macrumors 65816

    Jun 9, 2011
    Halfway between the Equator and North Pole
  3. jinsan thread starter macrumors newbie

    Feb 22, 2013
    It's the latest one (iPad 4 or iPad with retina display) and yes, I tried hard reset, too.
  4. phr0ze macrumors 6502a

    Jun 14, 2012
    Columbia, MD
    • Test you ipad connector with headphones. Try recording your voice with the headset to ensure the connector isn't broken. Even try slightly wiggling the headphone plug as you record.
    • The Square reader takes a certain flick of the wrist, perhaps because of the device form factor difference you are flicking it different.
    • Do you have a case on the ipad? Take it off and try again.
    • Get a second reader and try that.
  5. bobbysmith macrumors regular

    Nov 4, 2012
    Have you tried a circular or cone card reader?
  6. jinsan thread starter macrumors newbie

    Feb 22, 2013
    Headphone jack should be fine as I can hear and talk on skype using headset.
    I have two pair of card readers and both are not reading the cards. :(
  7. Flowers4550 macrumors newbie

    May 9, 2013
    Same issue with square and iPad

    Hello, I have had the same issue. My iPad took cards fine until square came out with the last update now it works part of the time then doesn't recognize a card is even being swiped the rest of the time. Did you figure out how to fix it??
  8. KeepCalmPeople macrumors 65816


    Sep 5, 2012
    San Francisco Bay Area, California
    Try reinstalling the app? I have the latest version of the app on my 4th gen iPad and it is still working (touch wood).
  9. Flowers4550 macrumors newbie

    May 9, 2013
    New iPad same issue

    I uninstalled the app, got a new square and had apple replace the iPad in case it was an issue with hardware. The iPad did fine for the first few days but it has started not working again.
  10. AuntPH macrumors newbie

    Jun 6, 2013
    I am having the same problem. Was working fine until latest update. I have the ipad 4. Works fine on my iphone5.
  11. JTravers macrumors 6502a

    Jun 28, 2010
    This probably isn't the issue, but after the Square reader is connected make sure to turn the volume all the way up before swiping.
  12. flipples macrumors newbie

    Oct 18, 2010
    Same issue here. We have several iPad Minis and and iPad Touch that stopped working. Only the big old iPad 1 still works. We went to the Apple store and they even swapped out an iPad Mini. We did a clean install (not from iCloud). We've verified that the card readers work on another iPad 4 without a problem.
  13. IrishCowboy macrumors newbie

    Oct 5, 2013
    Solved for me

    I had this same issue and everything I read didn't help.......but I finally tried this and it worked instantly, especially if you did any upgrades.
    Go to "Settings" > Privacy > Microphone. Make sure that Register is listed and turned on. Mine was turned off during my upgrade. Problem solved!! Hope it's that easy for you, too. Good luck!!
  14. saberahul macrumors 68040

    Nov 6, 2008
    square sent out an email on why it won't work and how to fix… you should be able to get in FAQs.



    When you update your Apple device to iOS 7, you may need to adjust your microphone in order to swipe payment cards with your card reader.

    If you have already updated to iOS 7, please allow Square Register to access the microphone. Here’s how:
    1. Go to Settings > Privacy > Microphone

    2. Turn on the Square Register slider

    3. Relaunch Square Register and swipe away!
    If you have not yet updated to iOS 7, your app will function normally. When you do update, follow the prompt to allow microphone access the first time you open Square Register.

    Visit the Square Help Center for help with iOS 7 troubleshooting.
    The Square Team
  15. icespur macrumors newbie

    Sep 14, 2011
    Problem with ios7 & square reader?

    Sometimes an iPad or phone will hookup to a wifi signal that requires a login. The unit thinks it is connected because it has a signal and tries to process the charge on that connection.

    Turn WIFI Off.
  16. marvso macrumors newbie

    Mar 6, 2014
    I had this problem but a paper clip fixed it. Some link/junk got into jack hole and prevented the square reader from seating properly. As soon as I dug out a small wad of link, it worked perfectly.
  17. yourecool macrumors newbie

    May 19, 2012

    THIS FIXED IT! Thank you l!

Share This Page