SR 2.2 MacBook Pro Won't Stay Asleep

Discussion in 'MacBook Pro' started by evilspoons, Apr 10, 2009.

  1. evilspoons macrumors member

    Joined:
    Sep 3, 2007
    #1
    I have a 2.2 GHz MacBook Pro (Santa Rosa) that has recently stopped sleeping correctly. I don't remember making any changes around the time it stopped working.

    I put the computer to sleep via any method (lid, power button, system menu) and anywhere from two minutes to two seconds later, the computer wakes up on me.

    I have tried resetting my NVRAM and SMC already.

    System.log tells me the wakeup event is a usb connection or disconnection, but I have absolutely nothing plugged into my MBP except the power cable.

    What the heck is going on here? It's driving me bonkers. If you can help me out I'll be extremely grateful.

    EDIT: Someone on this forum said in another thread that he fixed this problem (EHC1/EHC2 wakeup) by deleting "the usb preferences file" - does anyone have any idea what this might be? I tried nuking all the plist files with 'usb' in the title but there was only one and it didn't fix anything.

    System.log contents:
    Code:
    Apr 11 00:21:26 Macintosh kernel[0]: sleep
    Apr 11 00:21:26 Macintosh kernel[0]: Wake reason = EHC1 EHC2
    Apr 11 00:21:26 Macintosh kernel[0]: System Wake
    Apr 11 00:21:26 Macintosh kernel[0]: Previous Sleep Cause: 0
    Apr 11 00:21:26 Macintosh kernel[0]: USB (EHCI):Port 2 on bus 0xfa connected or disconnected: portSC(0x301002)
    Apr 11 00:21:28 Macintosh kernel[0]: AirPort: Link Up on en1
    Apr 11 00:21:28 Macintosh configd14: setting hostname to "Macintosh"
    Apr 11 00:21:32 Macintosh kernel[0]: AppleYukon2: 00000000,00000000 sk98osx_dnet - recovering from missed interrupt
    
    Macbook Pro SR 2.2 GHz Mac OS X (10.5.6)
     
  2. UltraNEO* macrumors 601

    UltraNEO*

    Joined:
    Jun 16, 2007
    Location:
    近畿日本
    #2
    We have the same system.. but i've yet to experience any oddities, yet..

    Anyway, the built-in iSight is connected to the logicboard via an internal USB connection, so are various internal other devices. It could be there's a loose connection inside the system that's causing it to wake up?

    If it's under warranty you might like to get it checked an possibly service by apple for the once over?
     
  3. nickcliborne macrumors regular

    Joined:
    Aug 25, 2008
    Location:
    Nut house
    #3
    Sometimes I like to put some soft music on and that helps my 2.2 SR sleep through the night. :p
     
  4. evilspoons thread starter macrumors member

    Joined:
    Sep 3, 2007
    #4
    Formatted and reinstalled 10.5 from scratch (the computer was originally upgraded from 10.4).

    Same problem, different error message in system.log. Updated with 10.5.6 combo updater, now I get exactly the same error message again.

    The part that confuses me is the EHCI isn't being used for any USB devices, as far as I can tell - all the internal USB devices seem to be attached via UHCI.

    USB Prober shows absolutely nothing attached to 0xFA and that it is just a "simulation" device (i.e. not even real hardware!).

    Code:
    High Speed device @ 1 (0xFA000000): .............................................   Hub device: "EHCI Root Hub Simulation"
        Port Information:   0x061d
               Built-in Root Hub
               Captive
               Internal Device
               Connected
               Enabled
        Device Descriptor   
            Descriptor Version Number:   0x0200
            Device Class:   9   (Hub)
            Device Subclass:   0
            Device Protocol:   1   (High Speed Single Transaction Translator)
            Device MaxPacketSize:   64
            Device VendorID/ProductID:   0x05AC/0x8006   (Apple Inc.)
            Device Version Number:   0x0200
            Number of Configurations:   1
            Manufacturer String:   2 "Apple Inc."
            Product String:   1 "EHCI Root Hub Simulation"
            Serial Number String:   0 (none)
        Configuration Descriptor   
            Length (and contents):   27
            Number of Interfaces:   1
            Configuration Value:   1
            Attributes:   0x60 (self-powered, remote wakeup)
            MaxPower:   0 ma
            Interface #0 - Hub   
        Hub Descriptor   
            Number of Ports:   0x04
            Hub Characteristics:   0x0 (Gang switched standalone hub with global overcurrent protection requiring 8 FS bit times and  no port indicators)
            PowerOnToGood time:   100 ms
            Controller current:   0 mA
            Device Removable (byte):   0x0
            Port Power Control Mask (byte):   0xff
    
    and from the IORegistry page:

    Code:
       0xfa: EHC2@1A,7  <class IOPCIDevice>
           IOService  <class IOService>
           AppleUSBEHCI  <class AppleUSBEHCI>
               1: EHCI Root Hub Simulation@1A,7  <class IOUSBRootHubDevice>
                   AppleUSBHub  <class AppleUSBHub>
                   IOUSBInterface@0  <class IOUSBInterface>
    
    Could someone with a SR MacBook Pro send me the output of the IORegistry and Bus Probe pages from USB Prober for comparison?
     
  5. evilspoons thread starter macrumors member

    Joined:
    Sep 3, 2007
    #5
    I have tried waking the computer up by pressing the keyboard, trackpad, and using the remote; none of them generate wakeup events that match the one I am getting above, therefore it is not a stuck keyboard key or freaking-out IR receiver.

    Bluetooth is off.


    For some reason, plugging a 32 MB USB flash drive into the left USB port makes the computer sleep for much longer, possibly indefinitely - I left it for 40 minutes and it never woke itself up. This is not a solution, but seems like a good hint towards a fix...
     

Share This Page